summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2015-06-08 08:30:35 -0400
committerJameson Pugh2015-06-08 08:30:35 -0400
commit02f1b27fe5a1726324adb985521453671b63e11f (patch)
tree4ec7ec0674683d442307efd499af5281be710d1b
downloadaur-libappstore.tar.gz
Initial commit using aur2git
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab64399dc9ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by makepkg 4.2.0
+# Tue Dec 30 20:47:26 UTC 2014
+pkgbase = libappstore
+ pkgdesc = Provides access to the Ubuntu app store through PackageKit
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://launchpad.net/libappstore
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ depends = packagekit
+ depends = sqlheavy
+ depends = libgee
+ depends = gtk3
+ source = https://launchpad.net/libappstore/0.x/0.1/+download/libappstore-0.1.tar.gz
+ sha256sums = 6f96168566db9c07cb1092faeb2a35dc1a0e2e41eb507bd57e70392cdc273177
+
+pkgname = libappstore
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..430a6e25d74f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Jameson Pugh <imntreal@gmail.com>
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=libappstore
+pkgver=0.1
+pkgrel=1
+pkgdesc="Provides access to the Ubuntu app store through PackageKit"
+arch=('i686' 'x86_64')
+url="http://launchpad.net/${pkgname}"
+license=('GPL' 'LGPL')
+depends=('packagekit' 'sqlheavy' 'libgee' 'gtk3')
+makedeps=('cmake')
+source=("https://launchpad.net/${pkgname}/0.x/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('6f96168566db9c07cb1092faeb2a35dc1a0e2e41eb507bd57e70392cdc273177')
+
+build() {
+ cd ${srcdir}/${pkgname}
+
+ [[ -d build ]] || mkdir build
+ cd build
+
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/build"
+
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: