summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Iooss2016-08-22 14:03:50 +0200
committerAlexandre Iooss2016-08-22 14:03:50 +0200
commitf033454a8e009ab97e48a9f37ac139b7129e07df (patch)
tree7f91f780a9e8448682bb65c033ffd68e6705472c
parente2fe8c3598885f0f66b4325d155e156f9e5b05ce (diff)
downloadaur-libarsal-git.tar.gz
Linked libs
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--libarsal-Makefile7
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2409b41deed0..2ad6fd530b49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libarsal-git
pkgdesc = ARSDK Software Abstraction Layer
pkgver = r313.0ba6cba
- pkgrel = 1
+ pkgrel = 2
url = http://developer.parrot.com/
arch = x86_64
license = custom
@@ -11,7 +11,7 @@ pkgbase = libarsal-git
source = libarsal-Makefile
source = LICENSE
sha256sums = SKIP
- sha256sums = 69ec1d1d2c7c95bc0f9e1645c5afab9cd8f81e4a6b9c6052a16e871b95e3efc3
+ sha256sums = d50a42d154b08732cffa40b3e0a88ed8ad452ce0106fe3616f771e8654dbc337
sha256sums = 1771e95329e9cb2bed04e023e330af3d558d0f13c0c1c5de0581f2880f149deb
pkgname = libarsal-git
diff --git a/PKGBUILD b/PKGBUILD
index 7e44366e1634..73bb22f0c100 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libarsal-git
pkgver=r313.0ba6cba
-pkgrel=1
+pkgrel=2
pkgdesc="ARSDK Software Abstraction Layer"
arch=(x86_64)
url="http://developer.parrot.com/"
@@ -21,7 +21,7 @@ source=('libarsal::git+https://github.com/Parrot-Developers/libARSAL'
'libarsal-Makefile'
'LICENSE')
sha256sums=('SKIP'
- '69ec1d1d2c7c95bc0f9e1645c5afab9cd8f81e4a6b9c6052a16e871b95e3efc3'
+ 'd50a42d154b08732cffa40b3e0a88ed8ad452ce0106fe3616f771e8654dbc337'
'1771e95329e9cb2bed04e023e330af3d558d0f13c0c1c5de0581f2880f149deb')
pkgver() {
diff --git a/libarsal-Makefile b/libarsal-Makefile
index 90591c90d25d..50c2f2d28148 100644
--- a/libarsal-Makefile
+++ b/libarsal-Makefile
@@ -1,6 +1,7 @@
CC = gcc
-CFLAGS = -fPIC -Wall -Wextra -O2 -g -lpthread -DHAVE_CONFIG_H -IConfig/linux -IIncludes
-LDFLAGS = -shared
+CFLAGS = -fPIC -Wall -Wextra -O2 -g -DHAVE_CONFIG_H -IConfig/linux -IIncludes
+LIBS = -lpthread
+LDFLAGS = -shared -Wl,-O1,-as-needed,-no-undefined,-z,relro,-z,now
RM = rm -f
TARGET_LIB = libarsal.so
@@ -21,7 +22,7 @@ OBJS = $(SRCS:.c=.o)
all: ${TARGET_LIB}
$(TARGET_LIB): $(OBJS)
- $(CC) ${LDFLAGS} -o $@ $^
+ $(CC) ${LDFLAGS} -o $@ $^ ${LIBS}
$(SRCS:.c=.d):%.d:%.c
$(CC) $(CFLAGS) -MM $< >$@