summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Kalb2016-03-14 12:45:52 +0100
committerMarkus Kalb2016-03-14 12:45:52 +0100
commit28df4606806622e01e2892c1297cdcf5c0ddcf3a (patch)
tree67cf1cb5fd2b20ac5709c702e5bd9b0ac207c609
downloadaur-28df4606806622e01e2892c1297cdcf5c0ddcf3a.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a5e5d39872e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libasdcp-cth
+ pkgdesc = open source implementation of SMPTE and the MXF Interop Sound & Picture Track File format.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://carlh.net/asdcplib
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = python2
+ makedepends = pkg-config
+ makedepends = boost
+ depends = libxml++>=2.6
+ depends = boost-libs
+ conflicts = asdcplib
+ source = libasdcp-cth-0.1.0.tar.bz2::http://carlh.net/downloads/asdcplib-cth/libasdcp-cth-0.1.0.tar.bz2
+ sha256sums = e8563fa51583f96c27e4c17ce9665ef07b26fb53aff1680793006a665736ed7a
+
+pkgname = libasdcp-cth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58e2f4cf8eaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Markus Kalb <mk@filmkreis.tu-darmstadt.de>
+# Contributor: Stefan Karner <stefan.karner@student.tuwien.ac.at>
+pkgname=libasdcp-cth
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="open source implementation of SMPTE and the MXF Interop Sound & Picture Track File format."
+arch=('i686' 'x86_64')
+url="http://carlh.net/asdcplib"
+license=('GPL')
+depends=('libxml++>=2.6' 'boost-libs')
+makedepends=('python2' 'pkg-config' 'boost')
+source=("${pkgname}-${pkgver}.tar.bz2::http://carlh.net/downloads/asdcplib-cth/${pkgname}-${pkgver}.tar.bz2")
+#http://carlh.net/downloads/libcxml/libcxml-0.12.0.tar.bz2o
+#http://carlh.net/downloads/asdcplib-cth/libasdcp-cth-0.1.0.tar.bz2
+sha256sums=('e8563fa51583f96c27e4c17ce9665ef07b26fb53aff1680793006a665736ed7a')
+conflicts=('asdcplib')
+
+
+build() {
+ CXXFLAGS="$CXXFLAGS -std=c++11"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 waf configure --prefix=/usr
+ python2 waf build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 waf install --destdir=$pkgdir
+}