diff options
author | Mike Pento | 2024-10-23 16:08:19 -0400 |
---|---|---|
committer | Mike Pento | 2024-10-23 16:08:19 -0400 |
commit | 1a31325102391a8ecdb879e686bd5372aaaf341e (patch) | |
tree | aac31b5b2364619a4ed11edc3a66876578b9ec40 | |
parent | fb1a281f45d7bc21cb7924fe56dc3f9afdbd73d6 (diff) | |
download | aur-libast.tar.gz |
Changed source URL, added patch for snprintf.c (possibly temporary, until a better solution is found).
-rw-r--r-- | .SRCINFO | 11 | ||||
-rw-r--r-- | PKGBUILD | 21 | ||||
-rw-r--r-- | snprintf.patch | 5 |
3 files changed, 23 insertions, 14 deletions
@@ -1,8 +1,8 @@ pkgbase = libast pkgdesc = The Library of Assorted Spiffy Things. pkgver = 0.7 - pkgrel = 3 - url = http://eterm.sourceforge.net + pkgrel = 4 + url = https://github.com/mej/libast arch = i686 arch = x86_64 license = BSD @@ -10,10 +10,11 @@ pkgbase = libast depends = pcre depends = libsm options = !libtool - source = http://www.eterm.org/download/libast-0.7.tar.gz + source = https://github.com/mej/libast/archive/refs/tags/0.7.tar.gz source = LICENSE.txt - md5sums = a9ec3b2da317f35869316e6d9571d296 + source = snprintf.patch + md5sums = a3e13cc80ffeff4b345fd8aa73e44bda md5sums = 97071898559acc4f900ceb6cb9579492 + md5sums = bff8084e2829e63a47b00d9e06366e24 pkgname = libast - @@ -1,24 +1,27 @@ -# $Id: PKGBUILD 40906 2011-03-01 14:45:04Z andrea $ -# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us> -# Contributor: Adam 'battlemidget' Stokes <adam.stokes@gmail.com> +# Maintainer: Mike Pento <mpento@darkforge.net> pkgname=libast pkgver=0.7 -pkgrel=3 +pkgrel=4 pkgdesc="The Library of Assorted Spiffy Things." arch=('i686' 'x86_64') -url="http://eterm.sourceforge.net" +url="https://github.com/mej/libast" license=('BSD') depends=('imlib2' 'pcre' 'libsm') options=('!libtool') -source=(http://www.eterm.org/download/${pkgname}-${pkgver}.tar.gz LICENSE.txt) -md5sums=('a9ec3b2da317f35869316e6d9571d296' - '97071898559acc4f900ceb6cb9579492') +source=(https://github.com/mej/libast/archive/refs/tags/${pkgver}.tar.gz LICENSE.txt snprintf.patch) +md5sums=('a3e13cc80ffeff4b345fd8aa73e44bda' + '97071898559acc4f900ceb6cb9579492' + 'bff8084e2829e63a47b00d9e06366e24') build() { cd ${srcdir}/${pkgname}-${pkgver} - ./configure --prefix=/usr --with-x + # hack of a patch for snprintf.c includes + patch --verbose src/snprintf.c < ../../snprintf.patch + + # args pass through to configure + ./autogen.sh --prefix=/usr --with-x make } diff --git a/snprintf.patch b/snprintf.patch new file mode 100644 index 000000000000..e2dde789aff3 --- /dev/null +++ b/snprintf.patch @@ -0,0 +1,5 @@ +10a11,14 +> #include <stdio.h> +> #include <stddef.h> +> #include <string.h> +> #include <ctype.h> |