summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Owens2020-04-28 22:08:31 -0500
committerNathan Owens2020-04-28 22:08:31 -0500
commitea04e73844bd734298cadc1ffbf5e5ccc00314db (patch)
tree2663dd9d4f0dd0d12e335f23a7d100f8b6c280f8
parent2e2ef9e729ae4ca66fe98e5c490503c86dec313d (diff)
downloadaur-libaxc.tar.gz
Update
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 33 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bc86ca7881e..e72189dd102b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,21 @@
pkgbase = libaxc
pkgdesc = Client lib for libsignal-protocol-c
- pkgver = 0.3.1
- pkgrel = 2
+ pkgver = 0.3.2
+ pkgrel = 1
url = https://github.com/gkdr/axc
arch = i686
arch = x86_64
license = GPL3
- depends = libsignal-protocol-c
- source = https://github.com/gkdr/axc/archive/v0.3.1.tar.gz
+ makedepends = git
+ makedepends = setconf
+ makedepends = glib2
+ makedepends = libsignal-protocol-c
+ source = git+https://github.com/gkdr/axc.git#tag=v0.3.2
source = build-without-submodule.patch
- md5sums = 19d82eda58fa0b449accdacf73e3f447
- md5sums = c854a97b3ade99b812bc1e6be743e848
+ source = https://raw.githubusercontent.com/signalapp/libsignal-protocol-c/master/src/session_builder_internal.h
+ sha256sums = SKIP
+ sha256sums = 53a2930e3afacad6f327db70013ccb50ceec6ab96f30794b04b8b5ce9b9cce8f
+ sha256sums = 597c4a197cd7ee6bda8d09f7204ae9b635cd26a78001f9d792470f219ee4a3d4
pkgname = libaxc
diff --git a/PKGBUILD b/PKGBUILD
index 35427e145d4e..e516e7c2b259 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,38 @@
# Maintainer: Johannes Wienke <languitar@semipol.de>
+# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
pkgname=libaxc
-pkgver=0.3.1
-pkgrel=2
+pkgver=0.3.2
+pkgrel=1
pkgdesc="Client lib for libsignal-protocol-c"
arch=('i686' 'x86_64')
url='https://github.com/gkdr/axc'
license=('GPL3')
-depends=('libsignal-protocol-c')
-makedepends=()
-source=("https://github.com/gkdr/axc/archive/v${pkgver}.tar.gz"
- "build-without-submodule.patch")
-md5sums=('19d82eda58fa0b449accdacf73e3f447'
- 'c854a97b3ade99b812bc1e6be743e848')
+makedepends=('git'
+ 'setconf'
+ 'glib2'
+ 'libsignal-protocol-c')
+source=("git+https://github.com/gkdr/axc.git#tag=v${pkgver}"
+ "build-without-submodule.patch"
+ "https://raw.githubusercontent.com/signalapp/libsignal-protocol-c/master/src/session_builder_internal.h")
+sha256sums=('SKIP'
+ '53a2930e3afacad6f327db70013ccb50ceec6ab96f30794b04b8b5ce9b9cce8f'
+ '597c4a197cd7ee6bda8d09f7204ae9b635cd26a78001f9d792470f219ee4a3d4')
prepare() {
- cd "${srcdir}/axc-${pkgver}"
- patch -p1 < "${srcdir}/build-without-submodule.patch"
+ cd "${srcdir}/axc"
+ git apply --stat "${srcdir}/build-without-submodule.patch"
+ setconf Makefile LDIR="$pkgdir"/usr/lib
+
}
build() {
- cd "${srcdir}/axc-${pkgver}"
- make
+ cd "${srcdir}/axc"
+ make CFLAGS="-I/usr/include/signal -I/usr/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I${srcdir}"
}
package() {
- cd "${srcdir}/axc-${pkgver}"
- mkdir -p "${pkgdir}/usr/lib"
- install build/*.a "${pkgdir}/usr/lib"
- mkdir -p "${pkgdir}/usr/include"
- install src/*.h "${pkgdir}/usr/include"
+ cd "${srcdir}/axc"
+ install -d "$pkgdir"/usr/include
+ install -Dm644 "$srcdir"/session_builder_internal.h src/*.h "${pkgdir}/usr/include"
}