summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Klimeš2020-01-27 15:38:06 +0100
committerJiří Klimeš2020-01-27 17:10:05 +0100
commit92c0c93f026405202e1a3c430f5fab411fded82a (patch)
treef80cacaf3c2e7428becc025d120e11b2d6f3efcb
parentcd7de9a63a253c621cb1dc82ae1aa495b433089b (diff)
downloadaur-92c0c93f026405202e1a3c430f5fab411fded82a.tar.gz
Enable building with pango-1.44 (that now depends on harfbuzz)
Upstream tecmake.mak is not updated with pango-harfbuzz-dependent stuff. So this is a temporary fix for tecmake.mak. This patch should be removed when the issue is fixed upstream. (No need to add harfbuzz as a package dependency, it gets installed via gtk3->pango->harfbuzz)
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b205873df17..fbe4e05f2b02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,6 +24,12 @@ md5sums=('578d4609719cb8060b3b7f722ec8f7e4'
prepare() {
# Statically link internal ftgl library. It contains Tecgraf's extensions needed by libcdgl.so
sed '/LIBS += ftgl/{ N; s/.*/SLIB += $(FTGL_LIB)\/libftgl.a/; }' -i "$srcdir"/cd/tecmake.mak
+
+ # patch to build with harfbuzz-ed pango (i.e. pango >= 1.44)
+ if [[ "$(vercmp $(pacman -Q pango | cut -d' ' -f2) 1:1.44)" -ge 0 ]]; then
+ sed 's/LIBS += gdk_pixbuf-2.0 pango-1.0 gobject-2.0 gmodule-2.0 glib-2.0/LIBS += gdk_pixbuf-2.0 pango-1.0 harfbuzz gobject-2.0 gmodule-2.0 glib-2.0/' -i "$srcdir"/cd/tecmake.mak
+ sed 's|STDINCS += $(GTK)/include/cairo $(GTK)/include/pango-1.0 $(GTK)/include/glib-2.0|STDINCS += $(GTK)/include/cairo $(GTK)/include/pango-1.0 $(GTK)/include/harfbuzz $(GTK)/include/glib-2.0|' -i "$srcdir"/cd/tecmake.mak
+ fi
}
build() {