summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2013-04-05 16:35:25 +0200
committerCedric Girard2013-04-05 16:35:25 +0200
commited6bc39bc29cd6046b7bb7b16a74f33ad7478d30 (patch)
tree86dff0c416b59029563fcb54ee60bc4f30b5d3eb
parent8539ce7b47e564e58f961a5bd4779ab1bbefd37e (diff)
downloadaur-ed6bc39bc29cd6046b7bb7b16a74f33ad7478d30.tar.gz
libcec-git PKGBUILD migrated to new VCS style
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD31
2 files changed, 14 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56f300336036..94d1835d101e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = libcec-git
pkgdesc = Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter
- pkgver = 20130325
+ pkgver = 2.0.4.77.g3ff78be
pkgrel = 1
+ epoch = 1
url = https://github.com/Pulse-Eight/libcec
arch = i686
arch = x86_64
@@ -12,6 +13,8 @@ pkgbase = libcec-git
provides = libcec
conflicts = libcec
options = !libtool
+ source = libcec::git+https://github.com/Pulse-Eight/libcec.git
+ md5sums = SKIP
pkgname = libcec-git
diff --git a/PKGBUILD b/PKGBUILD
index 4aa29200c8f1..3f3f3414f1c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Cedric Girard <girard.cedric@gmail.com>
pkgname=libcec-git
-pkgver=20130325
+epoch=1
+pkgver=2.0.4.77.g3ff78be
pkgrel=1
pkgdesc="Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter"
arch=('i686' 'x86_64')
@@ -12,36 +13,24 @@ depends=('udev>=151' 'lockdev')
provides=('libcec')
conflicts=('libcec')
options=('!libtool')
+source=('libcec::git+https://github.com/Pulse-Eight/libcec.git')
+md5sums=('SKIP')
-_gitroot="https://github.com/Pulse-Eight/libcec.git"
-_gitname="libcec"
+pkgver() {
+ cd "$srcdir"/libcec
+ git describe --tags | sed 's|libcec-||;s|-|.|g'
+}
build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
+ cd "$srcdir"/libcec
- sed 's/^LIBS_LIBCEC="$LIBS".*/LIBS_LIBCEC="$LIBS -fPIC"/' -i configure.ac
autoreconf -vif
./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/$_gitname-build"
+ cd "$srcdir"/libcec
make DESTDIR="$pkgdir/" install
}