summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustinus2016-09-18 01:22:49 +0800
committerjustinus2016-09-18 01:22:49 +0800
commit854fd07b58c642706d1038cf79986c1bdca3d2fa (patch)
treeface96cae5232479ee565dd0ab68051295e0c516
downloadaur-854fd07b58c642706d1038cf79986c1bdca3d2fa.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.install4
-rw-r--r--PKGBUILD49
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..80e91725d67e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libcs50
+ pkgdesc = CS50 Library for C (Harvard course)
+ pkgver = 7.1.0
+ pkgrel = 1
+ url = https://cs50.harvard.edu/
+ arch = x86_64
+ arch = i686
+ license = unknown
+ depends = glibc
+ conflicts = lib50-c-git
+ conflicts = lib50-c
+ source = https://github.com/cs50/lib50-c/archive/7.1.0.tar.gz
+ md5sums = 8feb784fcbccf8521b6fe5656bfe3112
+
+pkgname = libcs50
+
diff --git a/.install b/.install
new file mode 100644
index 000000000000..5e08b1ae330e
--- /dev/null
+++ b/.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo -e '\nInstead of using a makefile, you can add the following alias to your ~/.bashrc:'
+ echo -e " "alias make50="'"'make CC=clang CFLAGS="-ggdb3 -O0 -std=c99 -Wall -Werror" LDLIBS="-lcs50 -lm"'"'"'\n'
+}
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e94d0652acc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Jestine Paul <jestine dot paul at gmail dot com>
+pkgname=libcs50
+pkgver=7.1.0
+pkgrel=1
+epoch=
+pkgdesc="CS50 Library for C (Harvard course)"
+arch=('x86_64' 'i686')
+url="https://cs50.harvard.edu/"
+license=('unknown')
+groups=()
+depends=('glibc')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=('lib50-c-git' 'lib50-c')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/cs50/lib50-c/archive/$pkgver.tar.gz")
+noextract=()
+md5sums=('8feb784fcbccf8521b6fe5656bfe3112')
+validpgpkeys=()
+
+build() {
+ cd "lib50-c-$pkgver"
+ make build
+}
+
+package() {
+ install -dm755 "$pkgdir/"{usr/include,usr/lib,usr/share/man/man3}
+ install -Dm644 "$srcdir/lib50-c-$pkgver/build/usr/lib/libcs50.so" "$pkgdir/usr/lib/libcs50.so"
+ install -Dm644 "$srcdir/lib50-c-$pkgver/build/usr/include/cs50.h" "$pkgdir/usr/include/cs50.h"
+
+ install -Dm644 "$srcdir/lib50-c-$pkgver/build/usr/share/man/man3/eprintf.3" "$pkgdir/usr/share/man/man3/eprintf.3"
+ install -Dm644 "$srcdir/lib50-c-$pkgver/build/usr/share/man/man3/get_char.3" "$pkgdir/usr/share/man/man3/get_char.3"
+ install -Dm644 "$srcdir/lib50-c-$pkgver/build/usr/share/man/man3/get_double.3" "$pkgdir/usr/share/man/man3/get_double.3"
+ install -Dm644 "$srcdir/lib50-c-$pkgver/build/usr/share/man/man3/get_float.3" "$pkgdir/usr/share/man/man3/get_float.3"
+ install -Dm644 "$srcdir/lib50-c-$pkgver/build/usr/share/man/man3/get_int.3" "$pkgdir/usr/share/man/man3/get_int.3"
+ install -Dm644 "$srcdir/lib50-c-$pkgver/build/usr/share/man/man3/get_long_long.3" "$pkgdir/usr/share/man/man3/get_long_long.3"
+ install -Dm644 "$srcdir/lib50-c-$pkgver/build/usr/share/man/man3/get_string.3" "$pkgdir/usr/share/man/man3/get_string.3"
+}