summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorejjl2023-01-04 14:06:47 +0200
committerejjl2023-01-04 14:06:47 +0200
commit8a0671adecf409f192bf5f855e1ad18aaec7030f (patch)
tree0160bb896fe1adadd1be7858b6b5fb2113cb136b
parenta8fbf709eba39f0f831fc0b34edc902e3a6d46d9 (diff)
downloadaur-8a0671adecf409f192bf5f855e1ad18aaec7030f.tar.gz
Updated to v11.0.1
-rw-r--r--.install2
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 8 deletions
diff --git a/.install b/.install
index 5e08b1ae330e..ea9908a6af40 100644
--- a/.install
+++ b/.install
@@ -1,4 +1,4 @@
post_install() {
echo -e '\nInstead of using a makefile, you can add the following alias to your ~/.bashrc:'
- echo -e " "alias make50="'"'make CC=clang CFLAGS="-ggdb3 -O0 -std=c99 -Wall -Werror" LDLIBS="-lcs50 -lm"'"'"'\n'
+ echo -e " "alias make50="'"'make CC=clang CFLAGS="-fsanitize=signed-integer-overflow -fsanitize=undefined -ggdb3 -O0 -std=c11 -Wall -Werror -Wextra -Wno-sign-compare -Wno-unused-parameter -Wno-unused-variable -Wshadow" LDLIBS="-lcrypt -lcs50 -lm"'"'"'\n'
}
diff --git a/PKGBUILD b/PKGBUILD
index b03e4e3bf2a4..e130c00c9429 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
-# Maintainer: MayorBender <7480812+kingy9000@users.noreply.github.com>
+# Maintainer: Edmund Lodewijks <e.lodewijks@gmail.com>
+# Contributor: MayorBender <7480812+kingy9000@users.noreply.github.com>
# Contributor: Dan Beste <dan.ray.beste@gmail.com>
# Contributor: Justine Paul <jestine-paul@dsi.a-star.edu.sg>
# Contributor: justinus <jestine.paul@gmail.com>
pkgname='libcs50'
-pkgver=10.1.1
+pkgver=11.0.1
pkgrel=1
pkgdesc="CS50 Library for C"
arch=('i686' 'x86_64')
url='https://github.com/cs50/libcs50'
license=('MIT')
groups=('cs50')
-makedepends=('asciidoctor')
conflicts=('libcs50-git')
source=(
"${pkgname}-${pkgver}.tar.gz::https://github.com/cs50/${pkgname}/archive/v${pkgver}.tar.gz"
'Makefile.patch'
)
-sha256sums=(
- '32d5d7aafbb20f2b6181f7e79df6757699208324ab202bc5984f55669557a7d4'
- '4a10efd4f4f6b6bb18152a4f28497f7f8562aaa5aaf50c401d308827b922ef3f'
-)
+sha256sums=('339a3903d20af5b1eff27515a0756e33d182fdafc02c7712b11f5b34c6252788'
+ '4a10efd4f4f6b6bb18152a4f28497f7f8562aaa5aaf50c401d308827b922ef3f')
prepare() {
cd "${pkgname}-${pkgver}"