summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-11-05 07:46:24 -0500
committeracxz2020-11-05 07:46:24 -0500
commit5dc3ca47aa79ba4692581ef0c55dfc032e5e1851 (patch)
tree334c5b32ddec00fd54e85731971794e0d72cac19
parentf375881002c83c2e0204461f3253629b533e4db9 (diff)
downloadaur-5dc3ca47aa79ba4692581ef0c55dfc032e5e1851.tar.gz
add build opt deps to deps
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f237d8cebf33..afae7f0d5195 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libdart
pkgdesc = Dynamic Animation and Robotics Toolkit
pkgver = 6.9.5
- pkgrel = 1
+ pkgrel = 2
url = https://dartsim.github.io
arch = i686
arch = x86_64
@@ -12,19 +12,19 @@ pkgbase = libdart
depends = eigen
depends = fcl
depends = libccd
- optdepends = bullet: Bullet collision detection support
- optdepends = coin-or-ipopt: Ipopt optimizer support
- optdepends = flann: planning module support
- optdepends = nlopt: NLopt optimizer support
- optdepends = octomap: voxel grid shape support
- optdepends = ode: ODE collision detection support
- optdepends = openscenegraph: required for dart-gui-osg
+ depends = bullet
+ depends = coin-or-ipopt
+ depends = flann
+ depends = nlopt
+ depends = octomap
+ depends = ode
+ depends = openscenegraph
+ depends = tinyxml2
+ depends = urdfdom
+ depends = freeglut
+ depends = libxi
+ depends = libxmu
optdepends = pagmo: pagmo optimizer support
- optdepends = tinyxml2: parser support
- optdepends = urdfdom: urdf parser support
- optdepends = freeglut: GLUT GUI support
- optdepends = libxi: GLUT GUI support
- optdepends = libxmu: GLUT GUI support
provides = dartsim
source = libdart-6.9.5.tar.gz::https://github.com/dartsim/dart/archive/v6.9.5.tar.gz
sha256sums = 624c00b65e3a753cba50de038620860c86e2ac47b1793ae51f9427a4bcb14c32
diff --git a/PKGBUILD b/PKGBUILD
index 6a9b5cbd09f6..5bcaaea16abb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,25 +5,15 @@
pkgname=libdart
pkgver=6.9.5
-pkgrel=1
+pkgrel=2
pkgdesc="Dynamic Animation and Robotics Toolkit"
arch=('i686' 'x86_64')
url="https://dartsim.github.io"
license=('BSD')
-depends=('assimp' 'boost' 'eigen' 'fcl' 'libccd')
-optdepends=('bullet: Bullet collision detection support'
- 'coin-or-ipopt: Ipopt optimizer support'
- 'flann: planning module support'
- 'nlopt: NLopt optimizer support'
- 'octomap: voxel grid shape support'
- 'ode: ODE collision detection support'
- 'openscenegraph: required for dart-gui-osg'
- 'pagmo: pagmo optimizer support'
- 'tinyxml2: parser support'
- 'urdfdom: urdf parser support'
- 'freeglut: GLUT GUI support'
- 'libxi: GLUT GUI support'
- 'libxmu: GLUT GUI support')
+depends=('assimp' 'boost' 'eigen' 'fcl' 'libccd' 'bullet' 'coin-or-ipopt'
+ 'flann' 'nlopt' 'octomap' 'ode' 'openscenegraph' 'tinyxml2' 'urdfdom'
+ 'freeglut' 'libxi' 'libxmu')
+optdepends=('pagmo: pagmo optimizer support')
makedepends=('cmake')
provides=('dartsim')
_pkgname=dart