summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-05-11 11:54:55 -0400
committeracxz2019-05-11 11:54:55 -0400
commit6316f44c9f4418a8dda76a048368bbae572e6127 (patch)
treecf7e69c9ece4c11bda8dc26a7e9961a9fdbe885c
parent52870f7aa44a2f45637e51c06d496ea32a683286 (diff)
downloadaur-6316f44c9f4418a8dda76a048368bbae572e6127.tar.gz
Installation now occurs properly
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e993a8d3cd4c..0fb2a5d6d6d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libdart
pkgdesc = Dynamic Animation and Robotics Toolkit
pkgver = 6.8.4
- pkgrel = 1
+ pkgrel = 2
url = https://dartsim.github.io
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 2877d1335741..665ac17af2e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=libdart
pkgver=6.8.4
-pkgrel=1
+pkgrel=2
pkgdesc="Dynamic Animation and Robotics Toolkit"
arch=('i686' 'x86_64')
url="https://dartsim.github.io"
@@ -37,9 +37,11 @@ build() {
mkdir -p "${srcdir}/${_name}-${pkgver}/build"
cd "${srcdir}/${_name}-${pkgver}/build"
- cmake .. \
+ cmake \
-DCMAKE_BUILD_TYPE="${_buildtype}" \
- -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ "${srcdir}/${_name}-${pkgver}"
msg "Building the project"
make -j4
@@ -58,4 +60,5 @@ package() {
msg "Installing files"
make DESTDIR="${pkgdir}/" install
+
}