summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchmad Fathoni2021-09-05 02:01:53 +0700
committerAchmad Fathoni2021-09-05 02:28:40 +0700
commitdc46f74931a90a16cd9b49edd92ec5d7f05b8135 (patch)
treebe468d860800629a5f5a6748b51ef8328db7c944
parent2ec661e4fe8efc0f2dee0b31c40def4d1dfeb0cc (diff)
downloadaur-dc46f74931a90a16cd9b49edd92ec5d7f05b8135.tar.gz
6.11.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
-rw-r--r--bracket.patch30
3 files changed, 47 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ca5a91aa95f..0ef1c5b2f761 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libdart
pkgdesc = Dynamic Animation and Robotics Toolkit
- pkgver = 6.11.0
+ pkgver = 6.11.1
pkgrel = 1
url = https://dartsim.github.io
arch = i686
@@ -25,9 +25,12 @@ pkgbase = libdart
depends = freeglut
depends = libxi
depends = libxmu
+ depends = pagmo
optdepends = pagmo: pagmo optimizer support
provides = dartsim
- source = libdart-6.11.0.tar.gz::https://github.com/dartsim/dart/archive/v6.11.0.tar.gz
- sha256sums = 41d783d7f99d7b5ad1874336646f1bdfa33e146e0652a6c32d12eaa21505bd51
+ source = libdart-6.11.1.tar.gz::https://github.com/dartsim/dart/archive/v6.11.1.tar.gz
+ source = bracket.patch
+ sha256sums = 1a59b9d8f55433ad111089431826cd8abbec71f61c72a8558b655d92164f8de4
+ sha256sums = a6608b7f86aa412ed2e2395010fdb6fb47d34efbdb37b767427c8f02cb8eca65
pkgname = libdart
diff --git a/PKGBUILD b/PKGBUILD
index 9e6adbcea6cd..ebbdf17050d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: midgard <arch dot midgard "at symbol" janmaes "youknowwhat" com>
pkgname=libdart
-pkgver=6.11.0
+pkgver=6.11.1
pkgrel=1
pkgdesc="Dynamic Animation and Robotics Toolkit"
arch=('i686' 'x86_64')
@@ -12,13 +12,20 @@ url="https://dartsim.github.io"
license=('BSD')
depends=('assimp' 'boost' 'eigen' 'fcl' 'libccd' 'bullet' 'coin-or-ipopt'
'flann' 'nlopt' 'octomap' 'ode' 'openscenegraph' 'tinyxml2' 'urdfdom'
- 'glu' 'freeglut' 'libxi' 'libxmu')
+ 'glu' 'freeglut' 'libxi' 'libxmu' 'pagmo')
optdepends=('pagmo: pagmo optimizer support')
makedepends=('cmake')
provides=('dartsim')
_pkgname=dart
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/dartsim/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('41d783d7f99d7b5ad1874336646f1bdfa33e146e0652a6c32d12eaa21505bd51')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/dartsim/${_pkgname}/archive/v${pkgver}.tar.gz"
+ "bracket.patch")
+sha256sums=('1a59b9d8f55433ad111089431826cd8abbec71f61c72a8558b655d92164f8de4'
+ 'a6608b7f86aa412ed2e2395010fdb6fb47d34efbdb37b767427c8f02cb8eca65')
+
+prepare(){
+ cd "dart-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/bracket.patch"
+}
build() {
mkdir -p "${srcdir}/${_pkgname}-${pkgver}/build"
diff --git a/bracket.patch b/bracket.patch
new file mode 100644
index 000000000000..ff614c0bf95f
--- /dev/null
+++ b/bracket.patch
@@ -0,0 +1,30 @@
+diff --git a/dart/math/detail/Icosphere-impl.hpp b/dart/math/detail/Icosphere-impl.hpp
+index 69a25a4..4954a55 100644
+--- a/dart/math/detail/Icosphere-impl.hpp
++++ b/dart/math/detail/Icosphere-impl.hpp
+@@ -75,7 +75,7 @@ Icosphere<S>::computeIcosahedron(S radius)
+ const S x = radius * unitX;
+ const S z = radius * unitZ;
+
+- std::vector<Vector3> vertices = {{{-x, 0, z},
++ std::vector<Vector3> vertices = {{-x, 0, z},
+ {x, 0, z},
+ {-x, 0, -z},
+ {x, 0, -z},
+@@ -86,13 +86,13 @@ Icosphere<S>::computeIcosahedron(S radius)
+ {z, x, 0},
+ {-z, x, 0},
+ {z, -x, 0},
+- {-z, -x, 0}}};
++ {-z, -x, 0}};
+
+ static std::vector<Triangle> triangles
+- = {{{0, 4, 1}, {0, 9, 4}, {9, 5, 4}, {4, 5, 8}, {4, 8, 1},
++ = {{0, 4, 1}, {0, 9, 4}, {9, 5, 4}, {4, 5, 8}, {4, 8, 1},
+ {8, 10, 1}, {8, 3, 10}, {5, 3, 8}, {5, 2, 3}, {2, 7, 3},
+ {7, 10, 3}, {7, 6, 10}, {7, 11, 6}, {11, 0, 6}, {0, 1, 6},
+- {6, 1, 10}, {9, 0, 11}, {9, 11, 2}, {9, 2, 5}, {7, 2, 11}}};
++ {6, 1, 10}, {9, 0, 11}, {9, 11, 2}, {9, 2, 5}, {7, 2, 11}};
+
+ return std::make_pair(vertices, triangles);
+ }