summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathas2015-06-09 23:06:20 -0300
committerJonathas2015-06-09 23:06:20 -0300
commit010d3917dead64a4f8e2ad47403d2113e2c65e70 (patch)
tree36293c4b1cec12dc23ec54971c48dbaecd99b0f4
downloadaur-libdbf.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5d43b39ead5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libdbf
+ pkgdesc = Library for accessing the content of dBASE III, IV, and 5.0 files
+ pkgver = 0.0.2
+ pkgrel = 2
+ url = http://dbf.berlios.de
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = intltool
+ source = https://github.com/quentindemetz/libdbf/archive/0.0.2.tar.gz
+ md5sums = ebf9069074f282721947e5e3261f4bfb
+
+pkgname = libdbf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73c42ed3ff18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jon Ribeiro <contact@jonathas.com>
+pkgname=libdbf
+pkgver=0.0.2
+pkgrel=2
+pkgdesc="Library for accessing the content of dBASE III, IV, and 5.0 files"
+url="http://dbf.berlios.de"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('intltool')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=
+source=(https://github.com/quentindemetz/$pkgname/archive/$pkgver.tar.gz)
+md5sums=('ebf9069074f282721947e5e3261f4bfb')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ chmod +x autogen.sh
+ #rm configure install-sh depcomp missing
+ ./autogen.sh && ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=${pkgdir} install
+ find ${pkgdir} -name '*.la' -exec rm {} \;
+}
+