summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2023-12-05 17:13:38 +0100
committerDan Johansen2023-12-05 17:13:38 +0100
commit8654ce440463f8f9d54142cda6213ba7687d9fa2 (patch)
tree64c0807780156b9d915a215ad4fcc8f2ffd6a67c
parent82dc4f59b4f2a1a2b15e03ac00ddc24f9e313654 (diff)
downloadaur-libdesq.tar.gz
updated to 0.0.8
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86b42d95ef4f..1b55e5e9f0b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libdesq
pkgdesc = The DesQ library to handle X11 protocols, system calls, classes and functions to be used across the DesQ project.
- pkgver = 0.0.7
+ pkgver = 0.0.8
pkgrel = 1
url = https://gitlab.com/DesQ/libdesq
arch = x86_64
@@ -9,7 +9,8 @@ pkgbase = libdesq
makedepends = meson
makedepends = ninja
depends = qt5-base
- source = https://gitlab.com/DesQ/libdesq/-/archive/v0.0.7/libdesq-v0.0.7.tar.gz
- md5sums = 309dcac10d71352853c7eb69db60c2b1
+ depends = dfl-settings
+ source = https://gitlab.com/DesQ/libdesq/-/archive/v0.0.8/libdesq-v0.0.8.tar.gz
+ md5sums = 336d69a3d381f2ba5aa2d5c8fa118d44
pkgname = libdesq
diff --git a/PKGBUILD b/PKGBUILD
index 3ca22197b8d8..4cb5a8fe41f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
-# Maintainer: Dan Johansen <strit@manjaro.org>
+# Maintainer: Dan Johansen <strit@strits.dk>
## Build order:
## libdesq -> libdesqui -> desq-session -> desq-shell
pkgname=libdesq
-pkgver=0.0.7
+pkgver=0.0.8
pkgrel=1
pkgdesc="The DesQ library to handle X11 protocols, system calls, classes and functions to be used across the DesQ project."
arch=('x86_64' 'aarch64')
url="https://gitlab.com/DesQ/${pkgname}"
license=('GPL3')
-depends=('qt5-base')
+depends=('qt5-base' 'dfl-settings')
makedepends=('meson' 'ninja')
source=("https://gitlab.com/DesQ/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
-md5sums=('309dcac10d71352853c7eb69db60c2b1')
+md5sums=('336d69a3d381f2ba5aa2d5c8fa118d44')
build() {
cd "${pkgname}-v${pkgver}"
- meson .build --prefix=/usr --buildtype=release
+ meson setup .build --prefix=/usr --buildtype=release
ninja -C .build
}