summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLibrewish2020-08-06 13:42:24 +0530
committerLibrewish2020-08-06 13:42:24 +0530
commit25d8e8e6227c48e419f2db97afef1284c2798639 (patch)
tree64f58fe87c9e585f746ae51783bba075592cba99
downloadaur-libdesqui-git.tar.gz
update
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57aaee7828b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libdesqui-git
+ pkgdesc = DesQ UI Library. This library contains all the common UI widget which are to be used across the DesQ Project.
+ pkgver = r6.4b03a50
+ pkgrel = 1
+ url = https://gitlab.com/DesQ
+ arch = any
+ groups = desq-git
+ license = none
+ makedepends = git
+ depends = libdesq-git
+ provides = libdesqui
+ conflicts = libdesqui
+ source = git+https://gitlab.com/Desq/libdesqui.git
+ md5sums = SKIP
+
+pkgname = libdesqui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b21ab31ce526
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+_pkgname=libdesqui
+pkgname=${_pkgname}-git
+pkgver=r6.4b03a50
+pkgrel=1
+pkgdesc="DesQ UI Library. This library contains all the common UI widget which are to be used across the DesQ Project."
+arch=('any')
+url="https://gitlab.com/DesQ"
+license=('none')
+depends=('libdesq-git')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+groups=('desq-git')
+source=("git+https://gitlab.com/Desq/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}