summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Schulte2019-08-28 14:05:08 -0400
committerEric Schulte2019-08-28 14:07:53 -0400
commitfb038577e812195d54ffac06530f3d8c5d21ad74 (patch)
tree9783c85d1e3b1d9f4f10a34a168dc71bbdb10059
downloadaur-libehp-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd81dfcbee80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libehp-git
+ pkgdesc = Exception handling parsing support for Elf files (eh_frame, etc.)
+ pkgver = Release_1.0.0.r36.g1896c4f
+ pkgrel = 1
+ url = https://git.zephyr-software.com/opensrc/libehp
+ arch = x86_64
+ license = Apache License 2.0
+ makedepends = git
+ makedepends = cmake
+ optdepends = elfio: use the elfio library to parse elf files
+ provides = libehp
+ source = git+https://git.zephyr-software.com/opensrc/libehp.git
+ sha512sums = SKIP
+
+pkgname = libehp-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f0a5e20dbe66
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+libehp/
+libehp-*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..942683b5f2ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Eric Schulte <eschulte@grammatech.com>
+# Maintainer: Eric Schulte <eschulte@grammatech.com>
+_srcname=libehp
+pkgname=libehp-git
+pkgver=Release_1.0.0.r36.g1896c4f
+pkgrel=1
+pkgdesc="Exception handling parsing support for Elf files (eh_frame, etc.)"
+arch=('x86_64')
+url="https://git.zephyr-software.com/opensrc/libehp"
+license=('Apache License 2.0')
+optdepends=('elfio: use the elfio library to parse elf files')
+makedepends=('git' 'cmake')
+provides=('libehp')
+source=('git+https://git.zephyr-software.com/opensrc/libehp.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_srcname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_srcname/"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -Bbuild
+ make -C build
+}
+
+package() {
+ cd "$_srcname/build"
+ make DESTDIR="$pkgdir" install
+}