summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralyptik2017-08-01 12:36:03 -1000
committeralyptik2017-08-01 12:36:03 -1000
commit274069581263b43839acb1d9a525ce66eb4af566 (patch)
tree348a4c9944f359fa500a3c1d70ed02363d365184
downloadaur-libelf_manpages-git.tar.gz
addpkg: libelf_manpages-git v1.0.0-1
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96715ceb1628
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libelf_manpages-git
+ pkgdesc = Manpages for the libelf ELF access library.
+ pkgver = v1.0.0
+ pkgrel = 1
+ url = https://github.com/alyptik/libelf_manpages.git
+ arch = any
+ license = Solaris
+ options = zipman
+ source = git://github.com/alyptik/libelf_manpages.git
+ sha256sums = SKIP
+
+pkgname = libelf_manpages-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ed90588c8a59
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg
+*.tar.xz
+libelf_manpages/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb2c23ef917a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Joey Pabalinas <alyptik@protonmail.com>
+# Contributor: Joey Pabalinas <alyptik@protonmail.com>
+
+pkgname=libelf_manpages-git
+_pkgname="${pkgname%%-git}"
+pkgver=v1.0.0
+pkgrel=1
+pkgdesc="Manpages for the libelf ELF access library."
+arch=('any')
+url="https://github.com/alyptik/libelf_manpages.git"
+license=('Solaris')
+options=('zipman')
+source=("git://github.com/alyptik/libelf_manpages.git")
+sha256sums=('SKIP')
+
+pkgver()
+{
+ cd "${srcdir}/${_pkgname}"
+ git describe --tags |sed 's/-/./g'
+}
+
+prepare()
+{
+ cd "${srcdir}/${_pkgname}"
+ # conflicts with GNU binutils
+ rm -f man1/elfedit.1
+}
+
+package()
+{
+ cd "${srcdir}/${_pkgname}"
+ install -d "${pkgdir}/usr/share/man/man1"
+ install -d "${pkgdir}/usr/share/man/man3"
+ install -m 644 -C man1/* "${pkgdir}/usr/share/man/man1/"
+ install -m 644 -C man3/* "${pkgdir}/usr/share/man/man3/"
+}