summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Baumann2024-04-04 07:59:05 +0200
committerAndreas Baumann2024-04-04 07:59:05 +0200
commitd7fe657755473354ab91a36d49d1398ddeaa0a48 (patch)
treec1a122d7c9c6c916bfb135adc7b5af98b155bb83
parenta4d46ba4c14a22007d556c408c2681ffcea7feca (diff)
downloadaur-libfirm-git.tar.gz
more sane calculation of the git pkgver
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81feee2968a1..2c68638705b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = libfirm-git
pkgdesc = A c-lib for graph-based IR, optimizations and code gen for compilers
- pkgver = r18944.8bdd163f2
- pkgrel = 3
+ pkgver = 1.22.0.r1139.g95a238c
+ pkgrel = 1
url = https://pp.ipd.kit.edu/firm/
arch = any
license = GPL
makedepends = git
+ provides = libfirm=1.22.0.r1139.g95a238c
+ conflicts = libfirm
options = staticlibs
source = libfirm::git+https://github.com/libfirm/libfirm.git
source = libfirm.pc
diff --git a/PKGBUILD b/PKGBUILD
index 26d8d2956e48..d91cfad23098 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
_reponame=libfirm
pkgname="${_reponame}-git"
-pkgver=r18944.8bdd163f2
-pkgrel=3
+pkgver=1.22.0.r1139.g95a238c
+pkgrel=1
pkgdesc='A c-lib for graph-based IR, optimizations and code gen for compilers'
url="https://pp.ipd.kit.edu/firm/"
license=('GPL')
@@ -11,13 +11,12 @@ source=("${_reponame}::git+https://github.com/${_reponame}/${_reponame}.git"
libfirm.pc)
md5sums=('SKIP' '39a7ef0417669487524b95460962f6c7')
options=(staticlibs)
+conflicts=('libfirm')
+provides=("libfirm=${pkgver}")
pkgver() {
cd "$_reponame"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long --tags --abbrev=7 | sed 's/^libfirm-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {