summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2023-08-22 12:01:38 +0200
committerRicardo (XenGi) Band2023-08-22 12:01:38 +0200
commit199eeb4be4424829f721806425ddafd327b53276 (patch)
tree5a525360afc9dfca72ce5754097c2abcfff8d61c
parent6f9b34bf956457b3a2c0e58d29cbf5c272c20278 (diff)
downloadaur-libfmod.tar.gz
add checksum
-rw-r--r--[-rwxr-xr-x].SRCINFO5
-rw-r--r--.gitignore111
-rw-r--r--[-rwxr-xr-x]PKGBUILD7
3 files changed, 117 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03e9c90b7fc5..7f60da51144a 100755..100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = libfmod
pkgdesc = Libraries of the fmodex audio engine
pkgver = 4.44.64
- pkgrel = 1
+ pkgrel = 2
url = http://www.fmod.org/
arch = i686
arch = x86_64
license = custom
conflicts = fmodex
source = https://zdoom.org/files/fmod/fmodapi44464linux.tar.gz
- sha512sums = SKIP
+ sha256sums = 21a24f1394ae6981a47be0281f69ce41201801e59fb88084c49c5fd5459af010
pkgname = libfmod
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..39096d79551e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,111 @@
+# Created by https://www.toptal.com/developers/gitignore/api/archlinuxpackages,linux,macos,windows,vim
+# Edit at https://www.toptal.com/developers/gitignore?templates=archlinuxpackages,linux,macos,windows,vim
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+### Linux ###
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+
+### macOS ###
+# General
+.DS_Store
+.AppleDouble
+.LSOverride
+
+# Icon must end with two \r
+Icon
+
+# Thumbnails
+._*
+
+# Files that might appear in the root of a volume
+.DocumentRevisions-V100
+.fseventsd
+.Spotlight-V100
+.TemporaryItems
+.Trashes
+.VolumeIcon.icns
+.com.apple.timemachine.donotpresent
+
+# Directories potentially created on remote AFP share
+.AppleDB
+.AppleDesktop
+Network Trash Folder
+Temporary Items
+.apdisk
+
+### macOS Patch ###
+# iCloud generated files
+*.icloud
+
+### Vim ###
+# Swap
+[._]*.s[a-v][a-z]
+!*.svg # comment out if you don't need vector files
+[._]*.sw[a-p]
+[._]s[a-rt-v][a-z]
+[._]ss[a-gi-z]
+[._]sw[a-p]
+
+# Session
+Session.vim
+Sessionx.vim
+
+# Temporary
+.netrwhist
+# Auto-generated tag files
+tags
+# Persistent undo
+[._]*.un~
+
+### Windows ###
+# Windows thumbnail cache files
+Thumbs.db
+Thumbs.db:encryptable
+ehthumbs.db
+ehthumbs_vista.db
+
+# Dump file
+*.stackdump
+
+# Folder config file
+[Dd]esktop.ini
+
+# Recycle Bin used on file shares
+$RECYCLE.BIN/
+
+# Windows Installer files
+*.cab
+*.msix
+*.msm
+*.msp
+
+# Windows shortcuts
+*.lnk
+
+# End of https://www.toptal.com/developers/gitignore/api/archlinuxpackages,linux,macos,windows,vim
diff --git a/PKGBUILD b/PKGBUILD
index 15884a403d30..a9f40f703995 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=libfmod
pkgver=4.44.64
-pkgrel=1
+pkgrel=2
pkgdesc="Libraries of the fmodex audio engine"
arch=('i686' 'x86_64')
url="http://www.fmod.org/"
license=('custom')
conflicts=('fmodex')
-source=(https://zdoom.org/files/fmod/fmodapi44464linux.tar.gz)
-sha512sums=('SKIP')
+source=("https://zdoom.org/files/fmod/fmodapi44464linux.tar.gz")
+sha256sums=('21a24f1394ae6981a47be0281f69ce41201801e59fb88084c49c5fd5459af010')
package() {
if [ $CARCH == 'i686' ]; then
@@ -33,3 +33,4 @@ package() {
ln -s libfmodeventnet-${pkgver}.so ${pkgdir}/usr/lib/libfmodeventnet.so
install -Dm644 ${srcdir}/fmodapi${pkgver//./}linux/documentation/LICENSE.TXT ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
+