summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 14:45:03 +0200
committerAlexander F Rødseth2015-06-10 14:45:03 +0200
commit6fc90871a1e50dc61eb5d0bfce1c745167567c8e (patch)
treebc94ad76688cb4630e3298c1b3a87104c9e5291e
downloadaur-libgnomeprintui.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0b7276d7aea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libgnomeprintui
+ pkgdesc = User interface library for printing with GNOME
+ pkgver = 2.18.6
+ pkgrel = 5
+ url = http://www.gnome.org/
+ arch = x86_64
+ arch = i686
+ license = GPL
+ license = LGPL
+ makedepends = intltool
+ depends = libgnomeprint>=2.18.8
+ depends = libgnomecanvas>=2.30.2
+ depends = gnome-icon-theme
+ options = !libtool
+ source = http://ftp.gnome.org/pub/gnome/sources/libgnomeprintui/2.18/libgnomeprintui-2.18.6.tar.bz2
+ sha256sums = 156ae5b66e5dcc546efa2449048f792d76c55b30d93a9b67b0c69665e346f46a
+
+pkgname = libgnomeprintui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d71fd342d56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libgnomeprintui
+pkgver=2.18.6
+pkgrel=5
+pkgdesc='User interface library for printing with GNOME'
+arch=('x86_64' 'i686')
+license=('GPL' 'LGPL')
+depends=('libgnomeprint>=2.18.8' 'libgnomecanvas>=2.30.2' 'gnome-icon-theme')
+makedepends=('intltool')
+options=('!libtool')
+url='http://www.gnome.org/'
+source=("http://ftp.gnome.org/pub/gnome/sources/$pkgname/2.18/$pkgname-$pkgver.tar.bz2")
+sha256sums=('156ae5b66e5dcc546efa2449048f792d76c55b30d93a9b67b0c69665e346f46a')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: