summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid McInnis2019-01-20 03:14:10 -0800
committerDavid McInnis2019-01-20 03:14:10 -0800
commit34dd685dc5bd9084a1929dc2c2eb336d602eb0a8 (patch)
tree499ae0f3423026317f5bb036615ded8b917c4c4b
parent01c5035731169d3c8624294223ddaa02a85cc2e1 (diff)
downloadaur-libgpuarray-git.tar.gz
added license in package and added python to dependency based on comments
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 260f2a407b5e..c612a3f717b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libgpuarray-git
pkgdesc = Library to manipulate tensors on the GPU
- pkgver = 0.6.1.4.g56b2df4
+ pkgver = 0.7.6.8.g23f30c2
pkgrel = 2
url = https://github.com/Theano/libgpuarray
arch = i686
@@ -9,6 +9,7 @@ pkgbase = libgpuarray-git
makedepends = git
makedepends = cmake
depends = glibc
+ depends = python
provides = libgpuarray
source = git+https://github.com/Theano/libgpuarray.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a0171cbb7590..bed7910740ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Contributor: Jon Gjengset <jon@thesquareplanet.com>
pkgname=libgpuarray-git
_gitname=libgpuarray
-pkgver=0.6.1.4.g56b2df4
+pkgver=0.7.6.8.g23f30c2
pkgrel=2
pkgdesc="Library to manipulate tensors on the GPU"
arch=('i686' 'x86_64')
url="https://github.com/Theano/libgpuarray"
license=('MIT')
-depends=('glibc')
+depends=('glibc' 'python')
makedepends=('git' 'cmake')
provides=("${_gitname}")
source=("git+https://github.com/Theano/${_gitname}.git")
@@ -36,4 +36,5 @@ build() {
package() {
cd ${_gitname}/_build
make install
+ install -D -m644 "../LICENSE" "${pkgdir}/usr/share/licenses/libgpuarray-git/LICENSE"
}