summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlyxia Sother2024-02-05 20:59:09 +0100
committerAlyxia Sother2024-02-05 20:59:09 +0100
commit510bcfb352d85f43334bc0dd006bf6cb6a393a49 (patch)
tree6f92eec89b9399ac93bb265b9b9268a816dc1787
downloadaur-libhelium-git.tar.gz
[Meta] Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD58
-rw-r--r--libhelium-git.patch23
3 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4321f1cb0ba2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = libhelium-git
+ pkgdesc = The application framework for tauOS apps.
+ pkgver = r1382.6d02226
+ pkgrel = 1
+ url = https://github.com/tau-OS/libhelium
+ arch = x86_64
+ arch = aarch64
+ license = LGPL3
+ makedepends = dart-sass
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = meson
+ makedepends = ninja
+ makedepends = vala
+ depends = gtk4
+ depends = glib2
+ depends = libgee
+ provides = libhelium
+ conflicts = libhelium
+ source = libhelium::git+https://github.com/tau-OS/libhelium.git
+ source = libhelium-git.patch
+ sha256sums = SKIP
+ sha256sums = 577a8e5af057a6634e9bdd2c87072bb13d69a6ac41ab6e3d278055b8090cc84c
+
+pkgname = libhelium-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b03bca6e682a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Alyxia Sother <nylkvn@evfrhc.arg(rot13)>
+
+_pkgname=libhelium
+pkgname="${_pkgname}-git"
+pkgver=r1382.6d02226
+pkgrel=1
+pkgdesc="The application framework for tauOS apps."
+arch=('x86_64' 'aarch64')
+depends=('gtk4' 'glib2' 'libgee')
+makedepends=(
+ 'dart-sass'
+ 'git'
+ 'gobject-introspection'
+ 'meson'
+ 'ninja'
+ 'vala'
+)
+url="https://github.com/tau-OS/libhelium"
+license=('LGPL3')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+
+source=("$_pkgname::git+https://github.com/tau-OS/libhelium.git"
+ "$pkgname.patch")
+sha256sums=('SKIP'
+ '577a8e5af057a6634e9bdd2c87072bb13d69a6ac41ab6e3d278055b8090cc84c')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ meson subprojects download
+
+ # Removes the automatic schema compilation, we're doing this ourselves
+ patch --strip=1 --input="$srcdir/$pkgname.patch"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ arch-meson . builddir -Dvaladoc=false -Ddemo=false
+ meson compile -C builddir
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ meson install -C builddir --destdir "$pkgdir"
+
+ # Manually add the schema into the right data dir.
+ # We don't have to call glib-compile-schemas as glib2 contains a hook:
+ # <https://gitlab.archlinux.org/archlinux/packaging/packages/glib2/-/blob/main/glib-compile-schemas.hook?ref_type=heads>
+ install -Dm644 data/com.fyralabs.desktop.appearance.gschema.xml "$pkgdir/usr/share/glib-2.0/schemas/com.fyralabs.desktop.appearance.gschema.xml"
+}
diff --git a/libhelium-git.patch b/libhelium-git.patch
new file mode 100644
index 000000000000..b6f2cb1782dc
--- /dev/null
+++ b/libhelium-git.patch
@@ -0,0 +1,23 @@
+diff --color '--color=auto' --unified --unified --recursive --text libhelium/meson.build altered/meson.build
+--- libhelium/meson.build 2024-02-05 20:41:04.622113224 +0100
++++ altered/meson.build 2024-02-05 20:48:02.878874558 +0100
+@@ -101,19 +101,3 @@
+ if get_option('gidoc') or get_option('valadoc')
+ subdir('doc')
+ endif
+-
+-# GSettings schemas, merged from tau-gsettings-schemas since
+-# it's now standard for all Helium-based apps.
+-
+-settings_schemas = ['data/com.fyralabs.desktop.appearance.gschema.xml']
+-
+-gnome.compile_schemas(depend_files: files(settings_schemas))
+-
+-schemas_dir = get_option('prefix') / get_option('datadir') / 'glib-2.0' / 'schemas'
+-
+-install_data(settings_schemas, install_dir: schemas_dir)
+-
+-meson.add_install_script('glib-compile-schemas', schemas_dir)
+-
+-
+-# end schema stuff