summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2023-09-27 19:27:20 +0300
committerIvan Shapovalov2023-09-27 19:27:20 +0300
commit0cb0db3b9bd6be78ab599d145fad039f1aa718cb (patch)
tree8e91c947b9ddb64fc9743627eb483091e49e5b04
parent1f080ce6a234fcc99728943c3b728bc49aff3e8b (diff)
downloadaur-0cb0db3b9bd6be78ab599d145fad039f1aa718cb.tar.gz
Resync against extra/libimobiledevice, revert to openssl, depend on cython0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 9 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ce911de9f46..99ad74a67cc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,23 @@
pkgbase = libimobiledevice-git
pkgdesc = Library that talks the protocols to support iPhone and iPod Touch devices on Linux
- pkgver = 1.3.0.r179.g860ffb7
+ pkgver = 1.3.0.r190.g6fc41f5
pkgrel = 1
epoch = 1
url = http://www.libimobiledevice.org/
arch = x86_64
license = GPL2
license = LGPL2.1
- makedepends = autoconf-archive
- makedepends = cython
makedepends = git
+ makedepends = cython0
makedepends = python
- makedepends = python-setuptools
- depends = gnutls
- depends = libgcrypt
+ depends = glibc
depends = libplist-git
- depends = libtasn1
depends = libusbmuxd-git
depends = libimobiledevice-glue-git
+ depends = openssl
optdepends = python: for the Python bindings
provides = libimobiledevice-1.0.so
- provides = libimobiledevice=1.3.0.r179.g860ffb7
+ provides = libimobiledevice=1.3.0.r190.g6fc41f5
conflicts = libimobiledevice
source = git+https://github.com/libimobiledevice/libimobiledevice
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2112ebdbb898..c972708bfb5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,27 +6,14 @@
pkgname=libimobiledevice-git
epoch=1
-pkgver=1.3.0.r179.g860ffb7
+pkgver=1.3.0.r190.g6fc41f5
pkgrel=1
pkgdesc="Library that talks the protocols to support iPhone and iPod Touch devices on Linux"
url="http://www.libimobiledevice.org/"
arch=(x86_64)
license=(GPL2 LGPL2.1)
-depends=(
- gnutls
- libgcrypt
- libplist-git
- libtasn1
- libusbmuxd-git
- libimobiledevice-glue-git
-)
-makedepends=(
- autoconf-archive
- cython
- git
- python
- python-setuptools
-)
+depends=('glibc' 'libplist-git' 'libusbmuxd-git' 'libimobiledevice-glue-git' 'openssl')
+makedepends=('git' 'cython0' 'python')
optdepends=('python: for the Python bindings')
provides=(libimobiledevice-1.0.so "libimobiledevice=$pkgver")
conflicts=(libimobiledevice)
@@ -45,10 +32,7 @@ prepare() {
build() {
cd libimobiledevice
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --without-openssl \
- --with-gnutls
- #sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool # not needed anymore (libtool honors $LDFLAGS now)
+ ./configure --prefix=/usr
make
}