summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-09 12:03:33 +0200
committerMaxime Gauduin2015-06-09 12:03:33 +0200
commitef5777157ea520d42e5b16cc13de90e26aa84f97 (patch)
treefa2ce452b05b351e52523b99656666c345f39cc2
downloadaur-ef5777157ea520d42e5b16cc13de90e26aa84f97.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--MKPKG3
-rw-r--r--PKGBUILD68
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da722d25c56f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = libindicator
+ pkgdesc = A set of symbols and convenience functions for Ayatana indicators
+ pkgver = 12.10.1
+ pkgrel = 4
+ url = https://launchpad.net/libindicator
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gtk2
+ makedepends = gtk3
+ source = https://launchpad.net/libindicator/12.10/12.10.1/+download/libindicator-12.10.1.tar.gz
+ sha256sums = b2d2e44c10313d5c9cd60db455d520f80b36dc39562df079a3f29495e8f9447f
+
+pkgname = libindicator-gtk2
+ depends = gtk2
+ provides = libindicator
+ conflicts = libindicator
+
+pkgname = libindicator-gtk3
+ depends = gtk3
+ provides = libindicator3
+ conflicts = libindicator3
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..d0d02c0de73a
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,3 @@
+pkgname=('libindicator-gtk3')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c67bbe5dc2e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Balló György <ballogyor+arch@gmail.com>
+
+pkgbase=libindicator
+pkgname=('libindicator-gtk2' 'libindicator-gtk3')
+pkgver=12.10.1
+pkgrel=4
+pkgdesc='A set of symbols and convenience functions for Ayatana indicators'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/libindicator'
+license=('GPL')
+makedepends=('gtk2' 'gtk3')
+source=("https://launchpad.net/libindicator/${pkgver%.*}/${pkgver}/+download/libindicator-${pkgver}.tar.gz")
+sha256sums=('b2d2e44c10313d5c9cd60db455d520f80b36dc39562df079a3f29495e8f9447f')
+
+prepare() {
+ sed '/-Werror/s/$/ -Wno-deprecated-declarations/' -i libindicator-${pkgver}/libindicator/Makefile.{am,in}
+ cp -r libindicator-${pkgver} libindicator-gtk2-${pkgver}
+}
+
+build() {
+ cd libindicator-${pkgver}
+
+ ./configure \
+ --prefix='/usr' \
+ --libexecdir='/usr/lib/libindicator' \
+ --localstatedir='/var' \
+ --sysconfdir='/etc' \
+ --disable-static \
+ --disable-tests
+ make -j1
+
+ cd ../libindicator-gtk2-${pkgver}
+
+ ./configure \
+ --prefix='/usr' \
+ --localstatedir='/var' \
+ --libexecdir='/usr/lib/libindicator' \
+ --sysconfdir='/etc' \
+ --with-gtk='2' \
+ --disable-static \
+ --disable-tests
+ make -j1
+}
+
+package_libindicator-gtk2() {
+ depends=('gtk2')
+ provides=('libindicator')
+ conflicts=('libindicator')
+
+ cd libindicator-gtk2-${pkgver}
+
+ make -j1 DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/share
+}
+
+package_libindicator-gtk3() {
+ depends=('gtk3')
+ provides=('libindicator3')
+ conflicts=('libindicator3')
+
+ cd libindicator-${pkgver}
+
+ make -j1 DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/share
+}
+
+# vim: ts=2 sw=2 et: