summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Cardace2015-10-02 13:05:43 +0200
committerAntonio Cardace2015-10-02 13:05:43 +0200
commitc66a0778409b45c00a0ce6a253e951c595ad718d (patch)
tree05129213bd22cfaa0010c85d94a76dfe7184913d
parenta6c7b3f5bc48427c7756cd3880c80bd1dcc09a29 (diff)
downloadaur-liblwipv6.tar.gz
Now compiles from source
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 37 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d1cd58a9760..8cf9ceb73faf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,28 @@
pkgbase = liblwipv6
- pkgdesc = User level (lightweight) TCP/IP stack with IPv6 support.
+ pkgdesc = User level (lightweight) TCP/IP stack with IPv6 support
pkgver = 1.5a
pkgrel = 2
url = https://sourceforge.net/projects/view-os
install = liblwipv6.install
+ arch = i686
arch = x86_64
license = GPL2
- depends = glibc>=2.17
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = make
+ makedepends = libtool
+ depends = glibc
depends = libpcap>=0.8
+ depends = vde2
provides = liblwipv6=1.5a
conflicts = liblwipv6
replaces = liblwipv6
- source = http://ftp.us.debian.org/debian/pool/main/l/lwipv6/liblwipv6-2_1.5a-2_amd64.deb
+ source = http://http.debian.net/debian/pool/main/l/lwipv6/lwipv6_1.5a.orig.tar.gz
source = liblwipv6.install
- md5sums = 256c6a739c765988eafdd347f174635d
+ source = http://ftp.us.debian.org/debian/pool/main/l/lwipv6/liblwipv6-2_1.5a-2_amd64.deb
+ md5sums = 82258b72a5e0abbfd17920a8d7fa1906
md5sums = b4165e6142a92d65c8e14479486decc4
+ md5sums = 256c6a739c765988eafdd347f174635d
pkgname = liblwipv6
diff --git a/PKGBUILD b/PKGBUILD
index c078b91e8ae8..e45f0338ddfd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,39 @@
pkgname=liblwipv6
pkgver=1.5a
pkgrel=2
-pkgdesc="User level (lightweight) TCP/IP stack with IPv6 support."
-arch=('x86_64')
+pkgdesc="User level (lightweight) TCP/IP stack with IPv6 support"
+arch=('i686' 'x86_64')
url="https://sourceforge.net/projects/view-os"
license=('GPL2')
-depends=('glibc>=2.17'
- 'libpcap>=0.8')
+depends=('glibc' 'libpcap>=0.8' 'vde2')
+makedepends=('autoconf' 'automake' 'make' 'libtool')
provides=("$pkgname=$pkgver")
conflicts=("$pkgname")
replaces=("$pkgname")
install="${pkgname}.install"
-source=("http://ftp.us.debian.org/debian/pool/main/l/lwipv6/liblwipv6-2_1.5a-2_amd64.deb"
- "${pkgname}.install")
-md5sums=("256c6a739c765988eafdd347f174635d"
- "b4165e6142a92d65c8e14479486decc4")
+source=("http://http.debian.net/debian/pool/main/l/lwipv6/lwipv6_1.5a.orig.tar.gz"
+ "${pkgname}.install"
+ "http://ftp.us.debian.org/debian/pool/main/l/lwipv6/liblwipv6-2_1.5a-2_amd64.deb")
+md5sums=("82258b72a5e0abbfd17920a8d7fa1906"
+ "b4165e6142a92d65c8e14479486decc4"
+ "256c6a739c765988eafdd347f174635d")
-prepare() {
- cd "$srcdir"
- tar -xf data.tar.gz
+build(){
+ cd "$srcdir/lwipv6-${pkgver}"
+ autoreconf -i
+ if [ "$CARCH" == "x86_64" ]; then
+ ./configure --prefix="${pkgdir}/usr" --disable-static
+ else
+ ./configure --prefix="${pkgdir}/usr" --libdir="${pkgdir}/usr/lib32" --disable-static
+ fi
+ make
}
package() {
- cp -r "${srcdir}/usr" "$pkgdir"
+ mkdir -p ${pkgdir}/usr/share
+ tar -xf data.tar.gz
+ cp -r usr/share ${pkgdir}/usr/
+ cd "$srcdir/lwipv6-${pkgver}"
+ make install &> /dev/null
+ rm -rf ${pkgdir}/usr/include
}