summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilken 'Akiko' Gottwalt2015-11-27 11:14:57 +0100
committerWilken 'Akiko' Gottwalt2015-11-27 11:14:57 +0100
commit6cacc85e44af59d0a9b71a13b5cdce0e592323c3 (patch)
tree6b9bd0b9074d0ed6a927b9ecad2effdde5fd8f79
downloadaur-libomxil-component-vorbis.tar.gz
Initial commit of OpenMAX Bellagio Vorbis component build script including
64 bit and unused variables fix.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
-rw-r--r--libomxvorbis_64bit.patch41
-rw-r--r--libomxvorbis_unused_variables.patch38
4 files changed, 129 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09204c4fdee1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libomxil-component-vorbis
+ pkgdesc = An opensource implementation of the OpenMAX Integration Layer API - Vorbis component
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://omxil.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = glibc
+ source = http://downloads.sourceforge.net/project/omxil/components/libomxvorbis-0.1.tar.gz
+ md5sums = 66039038637f634ab591095fae511e1c
+
+pkgname = libomxil-component-vorbis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3aaae5839fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id$
+# Maintainer: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+# Contributor: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+pkgname=libomxil-component-vorbis
+pkgver=0.1
+pkgrel=1
+pkgdesc="An opensource implementation of the OpenMAX Integration Layer API - Vorbis component"
+arch=('i686' 'x86_64')
+url="http://omxil.sourceforge.net"
+license=('LGPL')
+depends=('glibc')
+source=("http://downloads.sourceforge.net/project/omxil/components/libomxvorbis-${pkgver}.tar.gz")
+md5sums=('66039038637f634ab591095fae511e1c')
+
+prepare() {
+ cd ${srcdir}/libomxvorbis-${pkgver}
+
+ [ -f Makefile ] && make distclean
+ patch -Np0 -i ../../libomxvorbis_64bit.patch
+ patch -Np0 -i ../../libomxvorbis_unused_variables.patch
+ autoreconf -fiv
+}
+
+build() {
+ cd ${srcdir}/libomxvorbis-${pkgver}
+
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd ${srcdir}/libomxvorbis-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/libomxvorbis_64bit.patch b/libomxvorbis_64bit.patch
new file mode 100644
index 000000000000..1082b80d76c2
--- /dev/null
+++ b/libomxvorbis_64bit.patch
@@ -0,0 +1,41 @@
+proper memory address printf
+
+Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+--- src/omx_vorbisdec_component.c.orig 2015-11-27 10:58:21.882260959 +0100
++++ src/omx_vorbisdec_component.c 2015-11-27 10:59:59.528036029 +0100
+@@ -57,7 +57,7 @@
+ return OMX_ErrorInsufficientResources;
+ }
+ } else {
+- DEBUG(DEB_LEV_FUNCTION_NAME, "In %s, Error Component %x Already Allocated\n", __func__, (int)openmaxStandComp->pComponentPrivate);
++ DEBUG(DEB_LEV_FUNCTION_NAME, "In %s, Error Component %p Already Allocated\n", __func__, openmaxStandComp->pComponentPrivate);
+ }
+
+ omx_vorbisdec_component_Private = openmaxStandComp->pComponentPrivate;
+@@ -282,14 +282,14 @@
+ ogg_int16_t convbuffer[4096];
+
+
+- DEBUG(DEB_LEV_FULL_SEQ, "input buf %x filled len : %d \n", (int)inputbuffer->pBuffer, (int)inputbuffer->nFilledLen);
++ DEBUG(DEB_LEV_FULL_SEQ, "input buf %p filled len : %d \n", inputbuffer->pBuffer, (int)inputbuffer->nFilledLen);
+ /** Fill up the current input buffer when a new buffer has arrived */
+ if(omx_vorbisdec_component_Private->isNewBuffer) {
+ omx_vorbisdec_component_Private->inputCurrBuffer = inputbuffer->pBuffer;
+ omx_vorbisdec_component_Private->inputCurrLength = inputbuffer->nFilledLen;
+ omx_vorbisdec_component_Private->positionInOutBuf = 0;
+
+- DEBUG(DEB_LEV_SIMPLE_SEQ, "new -- input buf %x filled len : %d \n", (int)inputbuffer->pBuffer, (int)inputbuffer->nFilledLen);
++ DEBUG(DEB_LEV_SIMPLE_SEQ, "new -- input buf %p filled len : %d \n", inputbuffer->pBuffer, (int)inputbuffer->nFilledLen);
+
+ /** for each new input buffer --- copy buffer content into into ogg sync state structure data */
+ vorbis_buffer = ogg_sync_buffer(&omx_vorbisdec_component_Private->oy, inputbuffer->nAllocLen);
+@@ -501,7 +501,7 @@
+ eos=1;
+ }
+
+- DEBUG(DEB_LEV_FULL_SEQ, "One output buffer %x len=%d is full returning\n", (int)outputbuffer->pBuffer, (int)outputbuffer->nFilledLen);
++ DEBUG(DEB_LEV_FULL_SEQ, "One output buffer %p len=%d is full returning\n", outputbuffer->pBuffer, (int)outputbuffer->nFilledLen);
+ }
+
+ /** setting parameter values
diff --git a/libomxvorbis_unused_variables.patch b/libomxvorbis_unused_variables.patch
new file mode 100644
index 000000000000..65c42cbccb43
--- /dev/null
+++ b/libomxvorbis_unused_variables.patch
@@ -0,0 +1,38 @@
+just fixed some unused variables
+
+Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+--- src/omx_vorbisdec_component.c.orig 2015-11-27 11:04:10.165742923 +0100
++++ src/omx_vorbisdec_component.c 2015-11-27 11:06:19.167893551 +0100
+@@ -268,7 +268,6 @@
+
+ omx_vorbisdec_component_PrivateType* omx_vorbisdec_component_Private = openmaxStandComp->pComponentPrivate;
+ OMX_U8* outputCurrBuffer;
+- OMX_U32 outputLength;
+ OMX_S32 result;
+ float **pcm;
+ OMX_S32 samples;
+@@ -277,7 +276,6 @@
+ OMX_S32 clipflag=0;
+ int val;
+ float *mono;
+- int eos=0;
+ char *vorbis_buffer;
+ ogg_int16_t convbuffer[4096];
+
+@@ -298,7 +296,6 @@
+ DEBUG(DEB_LEV_FULL_SEQ,"***** bytes read to buffer (of first header): %d \n",(int)inputbuffer->nFilledLen);
+ }
+ outputCurrBuffer = outputbuffer->pBuffer;
+- outputLength = outputbuffer->nAllocLen;
+ outputbuffer->nFilledLen = 0;
+ outputbuffer->nOffset = 0;
+
+@@ -498,7 +495,6 @@
+ }
+ if(ogg_page_eos(&omx_vorbisdec_component_Private->og)) {
+ DEBUG(DEB_LEV_FULL_SEQ, "In %s EOS Detected\n",__func__);
+- eos=1;
+ }
+
+ DEBUG(DEB_LEV_FULL_SEQ, "One output buffer %p len=%d is full returning\n", outputbuffer->pBuffer, (int)outputbuffer->nFilledLen);