summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilken 'Akiko' Gottwalt2015-11-27 08:01:07 +0100
committerWilken 'Akiko' Gottwalt2015-11-27 08:01:07 +0100
commitd7ad6ab1f7125b151df6b797728f0907592d4c10 (patch)
tree4643161aa9208cf97423f30cf69f7e9c6a8c40f7
downloadaur-libomxil-component-xvideo.tar.gz
Initial commit of OpenMAX Bellagio XVideo component build script including
64 bit fix.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
-rw-r--r--libomxxvideo_64bit.patch15
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0d2496d9f3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libomxil-component-xvideo
+ pkgdesc = An opensource implementation of the OpenMAX Integration Layer API - XVideo component
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://omxil.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = glibc
+ source = http://downloads.sourceforge.net/project/omxil/components/libomxxvideo-0.1.tar.gz
+ md5sums = 853c9892f68a14c9a3ff94148701de60
+
+pkgname = libomxil-component-xvideo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3b4b783b61f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id$
+# Maintainer: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+# Contributor: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+pkgname=libomxil-component-xvideo
+pkgver=0.1
+pkgrel=1
+pkgdesc="An opensource implementation of the OpenMAX Integration Layer API - XVideo component"
+arch=('i686' 'x86_64')
+url="http://omxil.sourceforge.net"
+license=('LGPL')
+depends=('glibc')
+source=("http://downloads.sourceforge.net/project/omxil/components/libomxxvideo-${pkgver}.tar.gz")
+md5sums=('853c9892f68a14c9a3ff94148701de60')
+
+prepare() {
+ cd ${srcdir}/libomxxvideo-${pkgver}
+
+ [ -f Makefile ] && make distclean
+ patch -Np0 -i ../../libomxxvideo_64bit.patch
+ autoreconf -fiv
+}
+
+build() {
+ cd ${srcdir}/libomxxvideo-${pkgver}
+
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd ${srcdir}/libomxxvideo-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/libomxxvideo_64bit.patch b/libomxxvideo_64bit.patch
new file mode 100644
index 000000000000..0e4959300935
--- /dev/null
+++ b/libomxxvideo_64bit.patch
@@ -0,0 +1,15 @@
+proper memory address printf
+
+Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+--- src/omx_xvideo_sink_component.c.orig 2015-11-27 06:53:07.609027879 +0100
++++ src/omx_xvideo_sink_component.c 2015-11-27 06:54:12.791678723 +0100
+@@ -77,7 +77,7 @@
+ return OMX_ErrorInsufficientResources;
+ }
+ } else {
+- DEBUG(DEB_LEV_FUNCTION_NAME, "In %s, Error Component %x Already Allocated\n", __func__, (int)openmaxStandComp->pComponentPrivate);
++ DEBUG(DEB_LEV_FUNCTION_NAME, "In %s, Error Component %p Already Allocated\n", __func__, openmaxStandComp->pComponentPrivate);
+ }
+
+ omx_xvideo_sink_component_Private = openmaxStandComp->pComponentPrivate;