summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Zukaitis2015-11-19 02:44:56 +0200
committerMarius Zukaitis2015-11-19 02:44:56 +0200
commit25a01f5f2c054eb468c731b622eb26f3fc524304 (patch)
tree110b29e1e7d435d6a923661508f5ccc6722cd5e8
downloadaur-libpam-blue.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
-rw-r--r--libpam-blue.patch56
3 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9b86cc468ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libpam-blue
+ pkgdesc = PAM module for local authenticaction with bluetooth devices.
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://launchpad.net/ubuntu/+source/libpam-blue
+ arch = any
+ license = GPL
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = libtool
+ makedepends = bluez-libs
+ depends = bluez
+ depends = bluez-libs
+ depends = glibc
+ source = http://archive.ubuntu.com/ubuntu/pool/universe/libp/libpam-blue/libpam-blue_0.9.0.orig.tar.gz
+ source = libpam-blue.patch
+ md5sums = b95c27f1c13bf4e07be9dd57b2f4db71
+ md5sums = 97a12dbda2e690fb7b7cacdeb8297b3b
+
+pkgname = libpam-blue
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7ea425a5fc4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=libpam-blue
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="PAM module for local authenticaction with bluetooth devices."
+arch=('any')
+url="https://launchpad.net/ubuntu/+source/libpam-blue"
+license=('GPL')
+depends=('bluez' 'bluez-libs' 'glibc')
+makedepends=('automake' 'autoconf' 'libtool' 'bluez-libs')
+source=("http://archive.ubuntu.com/ubuntu/pool/universe/libp/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz"
+ "libpam-blue.patch")
+md5sums=("b95c27f1c13bf4e07be9dd57b2f4db71"
+ "97a12dbda2e690fb7b7cacdeb8297b3b")
+
+prepare() {
+ cd "${srcdir}"/${pkgname}-${pkgver}.orig
+ patch -Np1 -i ../libpam-blue.patch
+}
+
+build() {
+ cd "${pkgname}-${pkgver}.orig"
+
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}.orig"
+
+ make DESTDIR="$pkgdir" install
+}
diff --git a/libpam-blue.patch b/libpam-blue.patch
new file mode 100644
index 000000000000..b3e4596d2653
--- /dev/null
+++ b/libpam-blue.patch
@@ -0,0 +1,56 @@
+diff -Naur --no-dereference libpam-blue-0.9.0.orig/aclocal.m4 libpam-blue-0.9.0.new/aclocal.m4
+--- libpam-blue-0.9.0.orig/aclocal.m4 2007-05-18 13:23:29.000000000 +0300
++++ libpam-blue-0.9.0.new/aclocal.m4 2015-11-18 21:03:30.657381520 +0200
+@@ -6289,7 +6289,7 @@
+ # ----------------------------
+ # Automake X.Y traces this macro to ensure aclocal.m4 has been
+ # generated from the m4 files accompanying Automake X.Y.
+-AC_DEFUN([AM_AUTOMAKE_VERSION], [am__api_version="1.8"])
++AC_DEFUN([AM_AUTOMAKE_VERSION], [am__api_version="1.15"])
+
+ # AM_SET_CURRENT_AUTOMAKE_VERSION
+ # -------------------------------
+diff -Naur --no-dereference libpam-blue-0.9.0.orig/configure libpam-blue-0.9.0.new/configure
+--- libpam-blue-0.9.0.orig/configure 2007-05-21 16:19:47.000000000 +0300
++++ libpam-blue-0.9.0.new/configure 2015-11-18 21:04:03.327100206 +0200
+@@ -7928,7 +7928,7 @@
+ exit 1
+ fi
+ gentoo_lt_version="1.5.18"
+-gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`
++gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
+ if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
+ { echo "$as_me:$LINENO: result: no" >&5
+ echo "${ECHO_T}no" >&6; }
+diff -Naur --no-dereference libpam-blue-0.9.0.orig/data/Makefile.am libpam-blue-0.9.0.new/data/Makefile.am
+--- libpam-blue-0.9.0.orig/data/Makefile.am 2007-05-18 13:23:29.000000000 +0300
++++ libpam-blue-0.9.0.new/data/Makefile.am 2015-11-18 21:29:24.667734819 +0200
+@@ -14,9 +14,9 @@
+ EXTRA_DIST = sample.conf
+
+ install-data-local:
+- test -d ${sysconfdir} || mkdir -p ${sysconfdir}
+- test -d ${sysconfdir}/security || mkdir -p ${sysconfdir}/security
+- cp -f $(srcdir)/sample.conf ${sysconfdir}/security/bluescan.conf
++ test -d ${DESTDIR}${sysconfdir} || mkdir -p ${DESTDIR}${sysconfdir}
++ test -d ${DESTDIR}${sysconfdir}/security || mkdir -p ${DESTDIR}${sysconfdir}/security
++ cp -f $(srcdir)/sample.conf ${DESTDIR}${sysconfdir}/security/bluescan.conf
+
+ uninstall-local:
+ rm -f ${sysconfdir}/security/bluescan.conf
+diff -Naur --no-dereference libpam-blue-0.9.0.orig/data/Makefile.in libpam-blue-0.9.0.new/data/Makefile.in
+--- libpam-blue-0.9.0.orig/data/Makefile.in 2007-05-18 13:23:29.000000000 +0300
++++ libpam-blue-0.9.0.new/data/Makefile.in 2015-11-18 21:30:06.436322287 +0200
+@@ -321,9 +321,9 @@
+
+
+ install-data-local:
+- test -d ${sysconfdir} || mkdir -p ${sysconfdir}
+- test -d ${sysconfdir}/security || mkdir -p ${sysconfdir}/security
+- cp -f $(srcdir)/sample.conf ${sysconfdir}/security/bluescan.conf
++ test -d ${DESTDIR}${sysconfdir} || mkdir -p ${DESTDIR}${sysconfdir}
++ test -d ${DESTDIR}${sysconfdir}/security || mkdir -p ${DESTDIR}${sysconfdir}/security
++ cp -f $(srcdir)/sample.conf ${DESTDIR}${sysconfdir}/security/bluescan.conf
+
+ uninstall-local:
+ rm -f ${sysconfdir}/security/bluescan.conf