summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-19 14:38:32 +0000
committerDaniel Bermond2018-11-19 14:38:32 +0000
commit44741e2eb8ff5418372a5972498dd3d7b0cf3f85 (patch)
tree223cd3388f9fec0131a519e25b8420cac713b7df
parenta4ee52571cee86379eb01b3826d36ec95ddd43b0 (diff)
downloadaur-libpciaccess-git.tar.gz
Use https for url and source. Other improvements.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a04a373e03d4..2761b99aa608 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = libpciaccess-git
pkgdesc = X11 PCI access library (git version)
- pkgver = 0.14.r0.g13854f6
+ pkgver = 0.14.r1.g44f3dd0
pkgrel = 1
- url = http://cgit.freedesktop.org/xorg/lib/libpciaccess/
+ url = https://cgit.freedesktop.org/xorg/lib/libpciaccess/
arch = i686
arch = x86_64
license = custom
@@ -11,7 +11,7 @@ pkgbase = libpciaccess-git
depends = glibc
provides = libpciaccess
conflicts = libpciaccess
- source = libpciaccess-git::git://anongit.freedesktop.org/xorg/lib/libpciaccess
+ source = git+https://anongit.freedesktop.org/git/xorg/lib/libpciaccess.git
sha256sums = SKIP
pkgname = libpciaccess-git
diff --git a/PKGBUILD b/PKGBUILD
index 9d8736a3760e..38695540826b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,46 @@
-# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
# Contributor: Det <nimetonmaili g-mail>
# Contributor: Matt Parnell /ilikenwf <parwok@gmail.com>
# Contributor: Jonathan <eyeswide@gmail.com>
pkgname=libpciaccess-git
-pkgver=0.14.r0.g13854f6
+_srcname=libpciaccess
+pkgver=0.14.r1.g44f3dd0
pkgrel=1
pkgdesc='X11 PCI access library (git version)'
arch=('i686' 'x86_64')
-url='http://cgit.freedesktop.org/xorg/lib/libpciaccess/'
+url='https://cgit.freedesktop.org/xorg/lib/libpciaccess/'
license=('custom')
depends=('glibc')
makedepends=('git' 'xorg-util-macros')
provides=('libpciaccess')
conflicts=('libpciaccess')
-source=("$pkgname"::'git://anongit.freedesktop.org/xorg/lib/libpciaccess')
+source=('git+https://anongit.freedesktop.org/git/xorg/lib/libpciaccess.git')
sha256sums=('SKIP')
+prepare() {
+ cd "$_srcname"
+
+ autoreconf -fiv
+}
+
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^libpciaccess\.//;s/^v//'
}
build() {
- cd "$pkgname"
+ cd "$_srcname"
- ./autogen.sh \
- --prefix='/usr' \
- --sysconfdir='/etc'
+ ./configure --prefix='/usr' --sysconfdir='/etc'
make
}
package() {
- cd "$pkgname"
+ cd "$_srcname"
make DESTDIR="$pkgdir" install