summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroot2022-01-26 00:30:24 +0100
committerroot2022-01-26 00:30:24 +0100
commitbe10ef06fbfe7a463ba1fbfbad8b793f812b2eff (patch)
tree75417e6ca7990ae1b83103b2cec659b3fe3eb13f
downloadaur-libproj4-projcompathack.tar.gz
Initial Commit.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD82
2 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70101d576132
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libproj4-projcompathack
+ pkgdesc = Cartographic Projections library, libraries only. Legacy version 4.x. Hack to be compatible with newer proj. Might not work fully, there to fulfill dependency for other legacy packages like perl-geo-proj4.
+ pkgver = 4.9.3
+ pkgrel = 1
+ url = https://proj.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = gmock
+ makedepends = gtest
+ depends = curl
+ depends = glibc
+ depends = libtiff
+ depends = sqlite
+ provides = libproj4=4.9.3
+ conflicts = libproj4
+ conflicts = proj4
+ source = https://download.osgeo.org/proj/proj-4.9.3.tar.gz
+ sha256sums = 6984542fea333488de5c82eea58d699e4aff4b359200a9971537cd7e047185f7
+
+pkgname = libproj4-projcompathack
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a2f1e591e10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,82 @@
+# Maintainer: dreieck
+# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Contributor: Mateusz Herych <heniekk@gmail.com>
+# Contributor: dibblethewrecker <dibblethewrecker.at.jiwe.dot.org>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+_pkgname=libproj4
+pkgname="${_pkgname}-projcompathack"
+pkgver=4.9.3
+pkgrel=1
+pkgdesc='Cartographic Projections library, libraries only. Legacy version 4.x. Hack to be compatible with newer proj. Might not work fully, there to fulfill dependency for other legacy packages like perl-geo-proj4.'
+arch=(
+ 'i686'
+ 'x86_64'
+)
+url="https://proj.org/"
+license=('MIT')
+depends=(
+ 'curl'
+ 'glibc'
+ 'libtiff'
+ 'sqlite'
+)
+makedepends=(
+ 'cmake'
+ 'gmock'
+ 'gtest'
+)
+provides=(
+ "${_pkgname}=${pkgver}"
+)
+conflicts=(
+ "${_pkgname}"
+ 'proj4'
+)
+source=(
+ "https://download.osgeo.org/proj/proj-${pkgver}.tar.gz"
+)
+sha256sums=(
+ '6984542fea333488de5c82eea58d699e4aff4b359200a9971537cd7e047185f7'
+)
+
+build() {
+ cd "${srcdir}"
+
+ cmake \
+ -S "proj-${pkgver}" \
+ -B build \
+ -DBUILD_CS2CS=OFF \
+ -DBUILD_GEOD=OFF \
+ -DBUILD_LIBPROJ_SHARED=ON \
+ -DBUILD_NAD2BIN=OFF \
+ -DBUILD_PROJ=OFF \
+ -DBUILD_TESTING=ON \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DJNI_SUPPORT=OFF \
+ -DPROJ4_TESTS=ON \
+ -DSELFTEST=OFF \
+ -DUSE_THREAD=ON \
+ -DUSE_EXTERNAL_GTEST=ON
+ cmake --build build
+}
+
+# check(){
+# cd "${srcdir}"
+#
+# ctest --test-dir build
+# }
+
+package() {
+ cd "${srcdir}"
+
+ DESTDIR="${pkgdir}" cmake --install build
+
+ rm -Rfv "${pkgdir}/usr"/{include/geodesic.h,lib/libproj.so,share/{man/man1,proj/{CH,GL27,nad.lst,nad27,nad83,other.extra,world}}}
+
+ install -D -v -m644 "proj-${pkgver}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ for _docfile in AUTHORS ChangeLog NEWS README; do
+ install -D -v -m644 "proj-${pkgver}/${_docfile}" "${pkgdir}/usr/share/doc/${pkgname}/${_docfile}"
+ done
+}