summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
committerKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
commitfd615427219b51fb179bed24e17e41313e995044 (patch)
tree5164448df9bce7e1ad4e47eff3d97df67054bbbe
downloadaur-fd615427219b51fb179bed24e17e41313e995044.tar.gz
moving files, making space for additional scripts, aur4 and other stuff
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69774b9f8f92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libreoffice-extension-languagetool
+ pkgdesc = An Open Source style and grammar checker (30 languages)
+ pkgver = 2.9.1
+ pkgrel = 1
+ url = http://www.languagetool.org/
+ arch = any
+ groups = libreoffice-extensions
+ license = LGPL
+ depends = libreoffice
+ noextract = LanguageTool-2.9.1.oxt
+ source = http://www.languagetool.org/download/LanguageTool-2.9.1.oxt
+ sha512sums = a3c848218aa65bb8b84e78a8d4374e28988736addc55de10307a9d6c8b8762081cf2736892a3d7adf714376a4508a80f3e52844540551fde6497596cb56e5099
+
+pkgname = libreoffice-extension-languagetool
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ec90452168a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: 3ED <krzysztof1987 /at/ gmail /dot/ com>
+# Contributor: jtts
+
+pkgname=libreoffice-extension-languagetool
+_pkgname=languagetool
+pkgver=2.9.1
+pkgrel=1
+pkgdesc="An Open Source style and grammar checker (30 languages)"
+arch=('any')
+url="http://www.languagetool.org/"
+license=('LGPL')
+groups=('libreoffice-extensions')
+depends=('libreoffice')
+source=("http://www.languagetool.org/download/LanguageTool-${pkgver}.oxt")
+noextract=("LanguageTool-${pkgver}.oxt")
+sha512sums=('a3c848218aa65bb8b84e78a8d4374e28988736addc55de10307a9d6c8b8762081cf2736892a3d7adf714376a4508a80f3e52844540551fde6497596cb56e5099')
+
+package() {
+ _DESTDIR="${pkgdir}/usr/lib/libreoffice/share/extensions/${_pkgname}/"
+ install -dm755 "${_DESTDIR}"
+ bsdtar -xf LanguageTool-${pkgver}.oxt -C "${_DESTDIR}"
+ chmod -R a=r,a+X,u+w "${_DESTDIR}"
+}