summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAskhat Bakarov2015-06-25 12:35:06 +0600
committerAskhat Bakarov2015-06-25 12:35:06 +0600
commitdd0144864456e1eeab0a303d88cbf110a58aeed8 (patch)
tree8649098acbb432114026fc658aa5f357ee3a7591
downloadaur-libreoffice-extension-pagination.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c722e0a6c822
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libreoffice-extension-pagination
+ pkgdesc = A little macro that adds a 'Insert / Page number...' dialog to writer. It eases the way you can add page numbers to a document.
+ pkgver = 1.3.10
+ pkgrel = 3
+ url = http://extensions.services.openoffice.org/project/pagination
+ arch = any
+ groups = libreoffice-extensions
+ license = Opensource
+ makedepends = unzip
+ depends = libreoffice
+ noextract = pagination-1.3.10.oxt
+ source = http://downloads.sourceforge.net/project/aoo-extensions/374/17/pagination-1.3.10.oxt
+ md5sums = 3273007fc21e97c56de335c700615190
+
+pkgname = libreoffice-extension-pagination
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c25619ed38ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+#
+pkgname=libreoffice-extension-pagination
+_pkgname=pagination
+pkgver=1.3.10
+pkgrel=3
+pkgdesc="A little macro that adds a 'Insert / Page number...' dialog to writer. It eases the way you can add page numbers to a document."
+arch=('any')
+url="http://extensions.services.openoffice.org/project/pagination"
+license=('Opensource')
+groups=('libreoffice-extensions')
+depends=('libreoffice')
+makedepends=('unzip')
+#source=('http://extensions.services.openoffice.org/e-files/374/17/Pagination-1.3.10.oxt')
+source=("http://downloads.sourceforge.net/project/aoo-extensions/374/17/${_pkgname}-${pkgver}.oxt")
+noextract=(${source[@]##*/})
+md5sums=('3273007fc21e97c56de335c700615190')
+
+package() {
+ #mkdir -p "$pkgdir/usr/lib/libreoffice/share/extensions/$_pkgname/"
+ #cp -R "$srcdir"/* "$pkgdir/usr/lib/libreoffice/share/extensions/$_pkgname/"
+ #rm "$pkgdir/usr/lib/libreoffice/share/extensions/$_pkgname/${_pkgname}-$pkgver.oxt"
+ #find "${pkgdir}/usr/lib/libreoffice/share/extensions/$_pkgname/" \( -type d -exec chmod 755 {} \; \) -o \( -type f -exec chmod 644 {} \; \)
+
+ _DESTDIR="${pkgdir}/usr/lib/libreoffice/share/extensions/${_pkgname}/"
+ install -dm755 "${_DESTDIR}"
+ unzip -q "$srcdir"/${_pkgname}-${pkgver}.oxt -d "${_DESTDIR}"
+ chmod -R g-w,o-w "${_DESTDIR}"
+}
+