summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfademind2018-02-26 10:41:13 +0100
committerfademind2018-02-26 10:41:13 +0100
commit56b2b996238e2dbd268eba279279cfa2fd2d80b4 (patch)
tree2abaa888da1dda8304884f43560869b85c4dc509
parent9836906144ae305a47d05c9557405112f9d30551 (diff)
downloadaur-56b2b996238e2dbd268eba279279cfa2fd2d80b4.tar.gz
Updated to upstream 6.0.1
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD15
3 files changed, 20 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe04a746a5e1..cb26e6a6fb1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
# Generated by mksrcinfo v8
-# Thu Feb 2 03:29:14 UTC 2017
+# Mon Feb 26 09:41:11 UTC 2018
pkgbase = libreoffice-fresh-rpm
pkgdesc = LGPL Office Suite installed from rpms
- pkgver = 5.3.0
+ pkgver = 6.0.1
pkgrel = 1
url = http://www.libreoffice.org
- arch = any
+ arch = i686
+ arch = x86_64
license = LGPL
makedepends = curl
makedepends = awk
@@ -18,8 +19,8 @@ pkgbase = libreoffice-fresh-rpm
optdepends = gst-plugins-good
optdepends = gst-plugins-bad
optdepends = gst-plugins-ugly
- source = https://download.documentfoundation.org/libreoffice/stable/5.3.0/rpm/x86_64/LibreOffice_5.3.0_Linux_x86-64_rpm.tar.gz
- sha256sums = 8ef2cbba3bebfdb2635451fbf40ac7119a1066dea67c3fcc354b80bc9a7870ef
+ source = https://download.documentfoundation.org/libreoffice/stable/6.0.1/rpm/x86_64/LibreOffice_6.0.1_Linux_x86-64_rpm.tar.gz
+ sha256sums = fd3bce0246fff46cc1627a000f42b157304f74132421c8370817fdfa675b61b6
pkgname = libreoffice-fresh-rpm
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..623d0e70ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
index 2f111b7ff1a1..2bba730e814e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
+# Maintainer : FadeMind <fademind@gmail.com>
# Contributor: Red_Squirrel <evangelion87d@gmail.com>
# Contributor: Xavier114fch <xavier114fch@gmail.com>
# Contributor: nachoig <areta@outlook.com.br>
# Contributor: nTia89 <mattia.b89@gmail.com>
# Contributor: Mark E. Lee <mark@markelee.com>
-# Maintainer : Mark E. Lee <mark@markelee.com>
## Changelog :
## changed build function to package function (since nothing is built)
@@ -54,7 +54,7 @@
## temporarily removing GPG sig checks
## updated to upstream 4.4.1
## updated to upstream 4.4.2
-## updated to remove "Y2K" problem. Credit to Tomasz PrzybyƂ for reporting the error. Credit to Mark Lee for identifying the cause and fix.
+## updated to remove "Y2K" problem. Credit to FadeMind for reporting the error. Credit to Mark Lee for identifying the cause and fix.
## updated to upstream 4.4.3
## updated to upstream 4.4.4
## updated to upstream 5.0.0
@@ -70,24 +70,26 @@
## updated to upstream 5.2.1
## updated to upstream 5.2.3
## updated to upstream 5.3.0
+## updated to upstream 6.0.1
pkgname=libreoffice-fresh-rpm
-pkgver=5.3.0
+pkgver=6.0.1
pkgrel=1
pkgdesc="LGPL Office Suite installed from rpms"
-arch=('any')
+arch=('i686' 'x86_64')
url='http://www.libreoffice.org'
license=('LGPL')
depends=('glibc>=2.5' 'gtk2>=2.10.4' 'xorg-server')
makedepends=('curl' 'awk')
optdepends=('jre7-openjdk' 'gtk3' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly')
+# WARNING sha256sums values should be taken from details page about rpm.tar.gz files from servers. DO NOT USE _updpgksums_ tool.
if [ "$(uname -m)" == "i686" ]; then ## convert bit architecture to libreoffice format
arch_mod='x86';
- sha256sums+=('c7040dbdcfb60b7c23b736b4e9b76a00e4301b93646ddf62c2712033fe16a2a0');
+ sha256sums+=('722ab3d224f08a4b36600955da14a43007749eff5c8fd610f272e49dd132dc86');
source+=("https://download.documentfoundation.org/libreoffice/stable/${pkgver}/rpm/${arch_mod}/LibreOffice_${pkgver}_Linux_${arch_mod/_/-}_rpm.tar.gz")
else
arch_mod='x86_64';
- sha256sums+=('8ef2cbba3bebfdb2635451fbf40ac7119a1066dea67c3fcc354b80bc9a7870ef')
+ sha256sums+=('fd3bce0246fff46cc1627a000f42b157304f74132421c8370817fdfa675b61b6')
source+=("https://download.documentfoundation.org/libreoffice/stable/${pkgver}/rpm/${arch_mod}/LibreOffice_${pkgver}_Linux_${arch_mod/_/-}_rpm.tar.gz")
fi;
@@ -176,3 +178,4 @@ for a in $(ls -d */); do ## loop for all directories found
done;
}
+sha256sums=('fd3bce0246fff46cc1627a000f42b157304f74132421c8370817fdfa675b61b6')