summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2016-09-26 22:41:50 +0200
committeranthraxx2016-09-26 22:41:50 +0200
commit98774b0123849a445faa5b311c1e2591af3531cc (patch)
tree3a59db4af2c128b98cbaf14e6e32a7f091f4fb43
downloadaur-libressl-git.tar.gz
addpkg: libressl-git 2.5.0.570.e168f3b-1
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD65
-rw-r--r--libressl-dummy-rand-egd.patch29
3 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7af9c671772a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = libressl-git
+ pkgdesc = FREE version of the SSL/TLS protocol forked from OpenSSL - HIGHLY EXPRIMENTAL ONLY
+ pkgver = 2.5.0.570.e168f3b
+ pkgrel = 1
+ url = http://www.libressl.org/
+ arch = i686
+ arch = x86_64
+ license = custom:Openssl
+ makedepends = git
+ depends = glibc
+ optdepends = ca-certificates
+ provides = libressl
+ provides = openssl
+ conflicts = libressl
+ conflicts = openssl
+ backup = etc/ssl/openssl.cnf
+ source = libressl-git::git+https://github.com/libressl-portable/portable
+ source = libressl-git-openbsd::git+https://github.com/libressl-portable/openbsd
+ source = libressl-dummy-rand-egd.patch
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = 73ca8a924a23f874287503453d939ecffa40f05760cd539b4773f3f28687ee1f2fa463ca3f2cad4ac5f57a49f3b6a918c015c8829112c61cb3ea7b798c0d110b
+
+pkgname = libressl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cad4554e0bc4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Reventlov <contact@volcanis.me>
+# Your system will break if you install this. For breaking purposes only
+
+pkgname=libressl-git
+pkgver=2.5.0.570.e168f3b
+pkgrel=1
+pkgdesc="FREE version of the SSL/TLS protocol forked from OpenSSL - HIGHLY EXPRIMENTAL ONLY"
+url="http://www.libressl.org/"
+arch=('i686' 'x86_64')
+license=('custom:Openssl')
+depends=('glibc')
+makedepends=('git')
+optdepends=('ca-certificates')
+backup=('etc/ssl/openssl.cnf')
+provides=('libressl' 'openssl')
+conflicts=('libressl' 'openssl')
+source=(${pkgname}::git+https://github.com/libressl-portable/portable
+ ${pkgname}-openbsd::git+https://github.com/libressl-portable/openbsd
+ libressl-dummy-rand-egd.patch)
+sha512sums=('SKIP'
+ 'SKIP'
+ '73ca8a924a23f874287503453d939ecffa40f05760cd539b4773f3f28687ee1f2fa463ca3f2cad4ac5f57a49f3b6a918c015c8829112c61cb3ea7b798c0d110b')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" \
+ "$(git describe --tags --abbrev=0|sed -r 's|v?(.*)|\1|g')" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+ ln -sf "${srcdir}/${pkgname}-openbsd" openbsd
+ ./autogen.sh
+ # Dummy RAND_egd() function - Can help to compile some stuff
+ # https://blog.hboeck.de/archives/851-LibreSSL-on-Gentoo.html
+ patch -p1 < "${srcdir}/libressl-dummy-rand-egd.patch"
+ # fix manpage symlink locations
+ sed -ri 's|(ln -sf )(.+) (.+)|\1\2.gz \3.gz|g' man/Makefile.in
+}
+
+build() {
+ cd ${pkgname}
+ ./configure --prefix=/usr --with-openssldir=/etc/ssl
+ make
+}
+
+check() {
+ cd ${pkgname}
+ make check
+}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
+ install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm "${pkgdir}/etc/ssl/cert.pem"
+ ln -s /usr/lib/libssl.so "${pkgdir}/usr/lib/libssl.so.1.0.0"
+ ln -s /usr/lib/libcrypto.so "${pkgdir}/usr/lib/libcrypto.so.1.0.0"
+ ln -s /usr/lib/libtls.so "${pkgdir}/usr/lib/libtls.so.1.0.0"
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/libressl-dummy-rand-egd.patch b/libressl-dummy-rand-egd.patch
new file mode 100644
index 000000000000..42ad5f83fb9b
--- /dev/null
+++ b/libressl-dummy-rand-egd.patch
@@ -0,0 +1,29 @@
+--- libressl-2.0.0/crypto/rand/rand_lib.c 2014-07-11 19:41:26.000000000 +0200
++++ libressl-2.0.0/crypto/rand/rand_lib.c 2014-07-12 00:16:22.583713400 +0200
+@@ -98,3 +98,15 @@
+ arc4random_buf(buf, num);
+ return 1;
+ }
++
++int
++RAND_egd(const char *path)
++{
++ return -1;
++}
++
++int
++RAND_egd_bytes(const char *path, int bytes)
++{
++ return -1;
++}
+--- libressl-2.0.0/include/openssl/rand.h 2014-07-11 19:41:25.000000000 +0200
++++ libressl-2.0.0/include/openssl/rand.h 2014-07-12 00:08:44.893435315 +0200
+@@ -96,6 +96,8 @@
+ int RAND_write_file(const char *file);
+ const char *RAND_file_name(char *file, size_t num);
+ int RAND_status(void);
++int RAND_egd(const char *path);
++int RAND_egd_bytes(const char *path,int bytes);
+ int RAND_poll(void);
+
+ /* BEGIN ERROR CODES */