summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Roijakkers2022-10-24 11:00:41 +0200
committerCedric Roijakkers2022-10-24 11:01:22 +0200
commiteb780ed02004cfd786d153dd831bc60e237999ed (patch)
treeb9c3e1cd2bc560d377722d51be71c192110f938a
parentba35caea1e228be6a6c5d0eaec5d02a33c18a046 (diff)
downloadaur-eb780ed02004cfd786d153dd831bc60e237999ed.tar.gz
Adopted package and updated to 4.9.
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD12
-rwxr-xr-xupdate.sh14
4 files changed, 40 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d76c6b00ad7..5c09a60fcc66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libreswan
pkgdesc = IPsec implementation with IKEv1 and IKEv2 keying protocols
- pkgver = 4.6
+ pkgver = 4.9
pkgrel = 1
url = https://libreswan.org/
install = libreswan.install
@@ -18,6 +18,7 @@ pkgbase = libreswan
depends = nss
depends = libcap-ng
depends = curl
+ depends = inetutils
depends = python3
optdepends = networkmanager-libreswan: NetworkManager support
optdepends = networkmanager-l2tp: L2TP support for NetworkManager using libreswan for IPSec
@@ -28,11 +29,11 @@ pkgbase = libreswan
backup = etc/ipsec.conf
backup = etc/ipsec.secrets
backup = etc/pam.d/pluto
- source = https://download.libreswan.org/libreswan-4.6.tar.gz
+ source = https://download.libreswan.org/libreswan-4.9.tar.gz
source = tmpfiles.conf
- md5sums = 3c6f2ab474534ead7abec57c9484ea75
+ md5sums = 584ee91ace5208db1a517b4c8e7a3971
md5sums = 77399a739ee99f8bc54837684d7c39d5
- sha256sums = 26396f4826a682735772a4689a7ce9ae2d409d166a4b72836fc55d14bad356ff
+ sha256sums = f642dcb635e909564ca8fd99ea44ab43f60723b4d76c158ed812978c45b398b9
sha256sums = 78265c690d58228c3bcc1a8793456172c39d493d268e9d9b1816288d0a47f573
pkgname = libreswan
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index 5091a3441899..9c5eedd961a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,6 @@
-# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Maintainer: Cedric Roijakkers <cedric [the at sign goes here] roijakkers [the dot sign goes here] be>.
+# Based on previous work from the following people:
+# Contributor: Chris Severance aur.severach aATt spamgourmet dott com
# Contributor: Gomasy <nyan@gomasy.jp>
# Contributor: Alexandre BIQUE <bique.alexandre@gmail.com>
# Contributor: Patrick Burroughs (Celti) <celti@celti.name>
@@ -6,14 +8,14 @@
set -u
pkgname='libreswan'
#pkgname+='-git'
-pkgver='4.6'
+pkgver='4.9'
pkgrel='1'
pkgdesc='IPsec implementation with IKEv1 and IKEv2 keying protocols'
arch=('i686' 'x86_64')
arch+=('aarch64') # yjun naumovitch
url='https://libreswan.org/'
license=('GPL' 'MPL')
-depends=('systemd' 'unbound' 'nss' 'libcap-ng' 'curl')
+depends=('systemd' 'unbound' 'nss' 'libcap-ng' 'curl' 'inetutils')
depends+=('python3')
optdepends=(
'networkmanager-libreswan: NetworkManager support'
@@ -28,9 +30,9 @@ source=(
"https://download.libreswan.org/${pkgname}-${pkgver%%.r*}.tar.gz"
'tmpfiles.conf'
)
-md5sums=('3c6f2ab474534ead7abec57c9484ea75'
+md5sums=('584ee91ace5208db1a517b4c8e7a3971'
'77399a739ee99f8bc54837684d7c39d5')
-sha256sums=('26396f4826a682735772a4689a7ce9ae2d409d166a4b72836fc55d14bad356ff'
+sha256sums=('f642dcb635e909564ca8fd99ea44ab43f60723b4d76c158ed812978c45b398b9'
'78265c690d58228c3bcc1a8793456172c39d493d268e9d9b1816288d0a47f573')
if [ "${pkgname%-git}" != "${pkgname}" ]; then
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..383ad354dddb
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,14 @@
+#!/usr/bin/env bash
+
+#
+# This script is used to semi-automatically run a build and update the PKGBUILD file locally.
+# It is not used in the AUR builds in any way, and is only for manual releasing purposes.
+#
+
+set -e
+
+rm -rf libreswan-*.pkg.tar.zst
+makepkg
+makepkg --printsrcinfo > .SRCINFO
+newversion=$(grep pkgver .SRCINFO | awk -F= '{print $2}' | sed -e 's/ //g')
+git commit -am "Updated to ${newversion}."