summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2015-06-12 12:09:36 +0100
committermschubert2015-06-12 12:09:36 +0100
commit7f6f988378ad91201a603f92ef1e71a9e8bb2d10 (patch)
treed58a00bb730737aa91de8eb1ab067251f453cb5e
downloadaur-7f6f988378ad91201a603f92ef1e71a9e8bb2d10.tar.gz
Initial import
-rw-r--r--.AURINFO25
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD37
3 files changed, 88 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..e07ff5f60743
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,25 @@
+pkgbase = libsbml
+ pkgdesc = XML-based description language for computational models in systems biology
+ pkgver = 5.10.2
+ pkgrel = 1
+ url = http://sbml.org/Software/libSBML
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = swig
+ makedepends = python2
+ makedepends = perl
+ makedepends = java-environment
+ depends = libxml2
+ optdepends = bzip2
+ optdepends = python2
+ optdepends = perl
+ optdepends = ruby
+ optdepends = java-runtime
+ optdepends = octave
+ optdepends = mono
+ source = http://sourceforge.net/projects/sbml/files/libsbml/5.10.2/stable/libSBML-5.10.2-core-plus-packages-src.tar.gz
+ options = !libtool
+
+pkgname = libsbml
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82971a48d63d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = libsbml
+ pkgdesc = XML-based description language for computational models in systems biology
+ pkgver = 5.10.2
+ pkgrel = 1
+ url = http://sbml.org/Software/libSBML
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = swig
+ makedepends = python2
+ makedepends = perl
+ makedepends = java-environment
+ depends = libxml2
+ optdepends = bzip2
+ optdepends = python2
+ optdepends = perl
+ optdepends = ruby
+ optdepends = java-runtime
+ optdepends = octave
+ optdepends = mono
+ options = !libtool
+ source = http://sourceforge.net/projects/sbml/files/libsbml/5.10.2/stable/libSBML-5.10.2-core-plus-packages-src.tar.gz
+ md5sums = 7d259943bf69df7aa870873a53399278
+
+pkgname = libsbml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4facb0b3da6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+
+pkgname=libsbml
+_pkgname=libSBML
+pkgver=5.10.2
+pkgrel=1
+pkgdesc="XML-based description language for computational models in systems biology"
+url="http://sbml.org/Software/libSBML"
+license=('LGPL')
+arch=('i686' 'x86_64')
+depends=('libxml2')
+optdepends=('bzip2' 'python2' 'perl' 'ruby' 'java-runtime' 'octave' 'mono')
+makedepends=('swig' 'python2' 'perl' 'java-environment')
+options=('!libtool')
+source=("http://sourceforge.net/projects/sbml/files/libsbml/$pkgver/stable/$_pkgname-$pkgver-core-plus-packages-src.tar.gz")
+md5sums=('7d259943bf69df7aa870873a53399278')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver-Source"
+
+ ./configure --prefix=/usr \
+ --with-python=yes --with-python-interpreter=/usr/bin/python2 \
+ --with-java=no \
+ --with-perl=yes \
+ --with-octave=no \
+ --with-csharp=no \
+ --with-ruby=no \
+ --with-matlab=no
+
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver-Source"
+ make DESTDIR="$pkgdir" install
+}
+