summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2021-11-30 11:57:37 +0100
committerXiretza2021-11-30 11:57:37 +0100
commit7bd36f61a73ace0a0f3cecb136bf0f0eb7b3d71d (patch)
tree18dbc7444a7fd206ac5a9221c99d1bf691b40957
parent9d37d29f87d773a797efdeb6a915d2f6ed93acef (diff)
downloadaur-libsigmf-git.tar.gz
Remove upstreamed patches
-rw-r--r--.SRCINFO8
-rw-r--r--0001-cmake-fix-installation-of-fbs-files.patch25
-rw-r--r--0002-fix-for-flatbuffers-v2.patch56
-rw-r--r--PKGBUILD12
4 files changed, 5 insertions, 96 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92d4ed167fde..f264042e1d8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libsigmf-git
pkgdesc = A header-only C++ library for working with SigMF metadata
- pkgver = r13.8ac7dbc
- pkgrel = 2
+ pkgver = r18.94445d4
+ pkgrel = 1
url = https://github.com/deepsig/libsigmf
arch = any
license = Apache
@@ -12,10 +12,6 @@ pkgbase = libsigmf-git
provides = libsigmf
conflicts = libsigmf
source = git+https://github.com/deepsig/libsigmf.git
- source = 0001-cmake-fix-installation-of-fbs-files.patch
- source = 0002-fix-for-flatbuffers-v2.patch
sha256sums = SKIP
- sha256sums = 03012d41f55c1a2f7a61f952c79d14e80bba1f2ee508d77a3d94fe78f3ab394c
- sha256sums = 9eae8483e26085999654ef9a633648b7025eca2c7a16b19b471ad7c189c47e04
pkgname = libsigmf-git
diff --git a/0001-cmake-fix-installation-of-fbs-files.patch b/0001-cmake-fix-installation-of-fbs-files.patch
deleted file mode 100644
index e89cb6043721..000000000000
--- a/0001-cmake-fix-installation-of-fbs-files.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 4584e99f26608eec9bdc8262aca377c2da85d256 Mon Sep 17 00:00:00 2001
-From: Xiretza <xiretza@xiretza.xyz>
-Date: Sat, 24 Apr 2021 17:19:38 +0200
-Subject: [PATCH] cmake: fix installation of fbs files
-
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 2f58c73..103dbef 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -177,7 +177,7 @@ configure_file(
- install( # install flatbuf proto defs
- DIRECTORY ${LIBSIGMF_GEN_HEADERS}/
- DESTINATION include/sigmf/fbs
-- FILES_MATCHING PATTERN "*.fbs)")
-+ FILES_MATCHING PATTERN "*.fbs")
- install( # install generated headers
- DIRECTORY ${LIBSIGMF_GEN_HEADERS}/
- DESTINATION include/sigmf
---
-2.31.1
-
diff --git a/0002-fix-for-flatbuffers-v2.patch b/0002-fix-for-flatbuffers-v2.patch
deleted file mode 100644
index 7b5de9a86b69..000000000000
--- a/0002-fix-for-flatbuffers-v2.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From 1caa1c81657ac96d73275564e146f8465a5dad18 Mon Sep 17 00:00:00 2001
-From: japm48 <japm48gh@gmail.com>
-Date: Sat, 25 Sep 2021 00:35:56 +0200
-Subject: [PATCH] Fix for flatbuffers v2
-
----
- src/flatbuffers_json_visitor.h | 15 ++++++++++++---
- 1 file changed, 12 insertions(+), 3 deletions(-)
-
-diff --git a/src/flatbuffers_json_visitor.h b/src/flatbuffers_json_visitor.h
-index 1c310ad..f8571d6 100644
---- a/src/flatbuffers_json_visitor.h
-+++ b/src/flatbuffers_json_visitor.h
-@@ -197,6 +197,15 @@ json_vector_to_chararray(flatbuffers::FlatBufferBuilder &fbb, const json &jvec,
- }
-
-
-+inline bool check_type_is_vector(const flatbuffers::TypeCode &tc) {
-+#if FLATBUFFERS_VERSION_MAJOR >= 2
-+ return tc.is_repeating;
-+#else
-+ return tc.is_vector;
-+#endif
-+}
-+
-+
- /**
- * Iterate through a typetable-- I'll be honest here. This is kind of bullshit. We need to create all of
- * the types like Strings, Lists, Vectors, and other flatbuffer types before we create our table. I'm not
-@@ -217,7 +226,7 @@ inline void IterateType(const flatbuffers::TypeTable *type_table, FromSigMFVisit
- for (size_t i = 0; i < type_table->num_elems; i++) {
- auto type_code = type_table->type_codes[i];
- auto type = static_cast<flatbuffers::ElementaryType>(type_code.base_type);
-- auto is_vector = type_code.is_vector != 0;
-+ auto is_vector = check_type_is_vector(type_code);
- auto ref_idx = type_code.sequence_ref;
- const flatbuffers::TypeTable *ref = nullptr;
- if (ref_idx >= 0) { ref = type_table->type_refs[ref_idx](); }
-@@ -277,7 +286,7 @@ inline void IterateType(const flatbuffers::TypeTable *type_table, FromSigMFVisit
- for (size_t i = 0; i < type_table->num_elems; i++) {
- auto type_code = type_table->type_codes[i];
- auto type = static_cast<flatbuffers::ElementaryType>(type_code.base_type);
-- auto is_vector = type_code.is_vector != 0;
-+ auto is_vector = check_type_is_vector(type_code);
- auto ref_idx = type_code.sequence_ref;
- const flatbuffers::TypeTable *ref = nullptr;
- if (ref_idx >= 0) { ref = type_table->type_refs[ref_idx](); }
-@@ -490,7 +499,7 @@ FlatBufferToJson(const uint8_t *buffer_root, const flatbuffers::TypeTable *typet
- // Gather all of the underlying info about this element in table
- auto type_code = typetable->type_codes[i];
- auto type = static_cast<flatbuffers::ElementaryType>(type_code.base_type);
-- auto is_vector = type_code.is_vector != 0;
-+ auto is_vector = check_type_is_vector(type_code);
- auto ref_idx = type_code.sequence_ref;
- const flatbuffers::TypeTable *ref = nullptr;
- if (ref_idx >= 0) { ref = typetable->type_refs[ref_idx](); }
diff --git a/PKGBUILD b/PKGBUILD
index 8505dc16674e..58769bfc5ea0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: xiretza <xiretza+aur@xiretza.xyz>
_pkgname=libsigmf
pkgname=$_pkgname-git
-pkgver=r13.8ac7dbc
-pkgrel=2
+pkgver=r18.94445d4
+pkgrel=1
pkgdesc="A header-only C++ library for working with SigMF metadata"
arch=(any)
url="https://github.com/deepsig/libsigmf"
@@ -12,12 +12,8 @@ makedepends=('cmake' 'git' 'flatbuffers' 'nlohmann-json')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+$url.git"
- "0001-cmake-fix-installation-of-fbs-files.patch"
- "0002-fix-for-flatbuffers-v2.patch"
)
-sha256sums=('SKIP'
- '03012d41f55c1a2f7a61f952c79d14e80bba1f2ee508d77a3d94fe78f3ab394c'
- '9eae8483e26085999654ef9a633648b7025eca2c7a16b19b471ad7c189c47e04')
+sha256sums=('SKIP')
pkgver() {
cd "$_pkgname"
@@ -26,8 +22,6 @@ pkgver() {
prepare() {
cd "$_pkgname"
- patch -p1 < "$srcdir/0001-cmake-fix-installation-of-fbs-files.patch"
- patch -p1 < "$srcdir/0002-fix-for-flatbuffers-v2.patch"
}
build() {