summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody P Schafer2019-08-31 22:51:41 -0400
committerCody P Schafer2019-08-31 22:51:41 -0400
commit2691f29eb756202b449d188de415c9ba06efabc1 (patch)
tree391e00e67c8af8d7c3c662b1c905d0a223137db0
parent1fb093b545493a7c3c0f56322ea1b6f73f737ed5 (diff)
downloadaur-2691f29eb756202b449d188de415c9ba06efabc1.tar.gz
fix build with doxygen 1.8.16
-rw-r--r--.SRCINFO4
-rw-r--r--0001-doxyfile-work-around-doxygen-1.8.16-bug.patch33
-rw-r--r--PKGBUILD22
3 files changed, 52 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f6d9293edfe..2421f768dfdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libsigrok-git
pkgdesc = Client software that supports various hardware logic analyzers, core library (git version)
- pkgver = 0.2.1.r3225.gea7a83a4
+ pkgver = 0.2.1.r3425.gf6129c8f
pkgrel = 1
url = http://www.sigrok.org/wiki/Libsigrok
arch = armv6h
@@ -20,6 +20,8 @@ pkgbase = libsigrok-git
provides = libsigrok
conflicts = libsigrok
source = git://sigrok.org/libsigrok
+ source = file://0001-doxyfile-work-around-doxygen-1.8.16-bug.patch
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = libsigrok-git
diff --git a/0001-doxyfile-work-around-doxygen-1.8.16-bug.patch b/0001-doxyfile-work-around-doxygen-1.8.16-bug.patch
new file mode 100644
index 000000000000..5a55b56ec0ed
--- /dev/null
+++ b/0001-doxyfile-work-around-doxygen-1.8.16-bug.patch
@@ -0,0 +1,33 @@
+From 515532cf19da948ec72c0cd19b44b5b5133910d2 Mon Sep 17 00:00:00 2001
+From: Cody P Schafer <dev@codyps.com>
+Date: Sat, 31 Aug 2019 22:45:06 -0400
+Subject: [PATCH] doxyfile: work around doxygen 1.8.16 bug
+
+Behavior of FILE_PATTERNS was unintentionally changed in doxygen 1.8.16,
+this lead to the libsigrok doxygen invocation generating almost no data,
+and missing all the enums needed for the binding generation, resulting
+in build failures.
+
+Workaround this by commenting out `FILE_PATTERNS`.
+
+Upstream-issue: https://github.com/doxygen/doxygen/issues/7190
+---
+ Doxyfile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Doxyfile b/Doxyfile
+index 252e504e..729340e2 100644
+--- a/Doxyfile
++++ b/Doxyfile
+@@ -763,7 +763,7 @@ INPUT_ENCODING = UTF-8
+ # *.md, *.mm, *.dox, *.py, *.f90, *.f, *.for, *.tcl, *.vhd, *.vhdl, *.ucf,
+ # *.qsf, *.as and *.js.
+
+-FILE_PATTERNS =
++#FILE_PATTERNS =
+
+ # The RECURSIVE tag can be used to specify whether or not subdirectories should
+ # be searched for input files as well.
+--
+2.23.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 438f4e698ddb..c5e8d2470aa5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_gitname='libsigrok'
pkgname="${_gitname}-git"
-pkgver=0.2.1.r3225.gea7a83a4
+pkgver=0.2.1.r3425.gf6129c8f
pkgrel=1
pkgdesc="Client software that supports various hardware logic analyzers, core library (git version)"
arch=('armv6h' 'armv7h' 'i686' 'x86_64')
@@ -15,28 +15,38 @@ depends=('libzip' 'libftdi' 'alsa-lib' 'libserialport-git' 'glibmm' 'libieee1284
makedepends=('git' 'autoconf-archive' 'doxygen')
conflicts=("${_gitname}")
provides=("${_gitname}")
-source=("git://sigrok.org/${_gitname}")
-sha512sums=('SKIP')
+source=("git://sigrok.org/${_gitname}"
+ "file://0001-doxyfile-work-around-doxygen-1.8.16-bug.patch"
+)
+sha512sums=('SKIP' 'SKIP')
pkgver() {
cd "${srcdir}/${_gitname}"
git describe --exclude 'libsigrok-unreleased' --long | sed 's/^libsigrok-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${srcdir}/${_gitname}"
+ patch -Np1 <../0001-doxyfile-work-around-doxygen-1.8.16-bug.patch
+}
+
build() {
+ mkdir -p "${srcdir}/build"
cd "${srcdir}/${_gitname}"
-
./autogen.sh
- PYTHON=python2 ./configure --prefix=/usr --disable-java
+
+ cd "${srcdir}/build"
+ ../${_gitname}/configure --prefix=/usr --disable-java
make
}
package() {
- cd "${srcdir}/${_gitname}"
+ cd "${srcdir}/build"
make DESTDIR="${pkgdir}" PREFIX=/usr install
+ cd ../"${_gitname}"
install -Dm 644 'contrib/60-libsigrok.rules' "${pkgdir}/usr/lib/udev/rules.d/60-libsigrok.rules"
install -Dm 644 'contrib/61-libsigrok-uaccess.rules' "${pkgdir}/usr/lib/udev/rules.d/61-libsigrok-uaccess.rules"
}