summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody Schafer2019-10-21 13:21:08 -0400
committerCody Schafer2019-10-21 13:21:08 -0400
commit4ef89dcd7ef5eb8f0bfd06016d67e343532489e1 (patch)
treed28dc838976c3137b095be2bb78d12d100fe78d9
parent2691f29eb756202b449d188de415c9ba06efabc1 (diff)
downloadaur-4ef89dcd7ef5eb8f0bfd06016d67e343532489e1.tar.gz
fix for doxygen changes
-rw-r--r--.SRCINFO2
-rw-r--r--0001-doxyfile-work-around-doxygen-1.8.16-bug.patch33
-rw-r--r--PKGBUILD14
3 files changed, 5 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2421f768dfdd..9d201646c598 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,8 +20,6 @@ pkgbase = libsigrok-git
provides = libsigrok
conflicts = libsigrok
source = git://sigrok.org/libsigrok
- source = file://0001-doxyfile-work-around-doxygen-1.8.16-bug.patch
- sha512sums = SKIP
sha512sums = SKIP
pkgname = libsigrok-git
diff --git a/0001-doxyfile-work-around-doxygen-1.8.16-bug.patch b/0001-doxyfile-work-around-doxygen-1.8.16-bug.patch
deleted file mode 100644
index 5a55b56ec0ed..000000000000
--- a/0001-doxyfile-work-around-doxygen-1.8.16-bug.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 515532cf19da948ec72c0cd19b44b5b5133910d2 Mon Sep 17 00:00:00 2001
-From: Cody P Schafer <dev@codyps.com>
-Date: Sat, 31 Aug 2019 22:45:06 -0400
-Subject: [PATCH] doxyfile: work around doxygen 1.8.16 bug
-
-Behavior of FILE_PATTERNS was unintentionally changed in doxygen 1.8.16,
-this lead to the libsigrok doxygen invocation generating almost no data,
-and missing all the enums needed for the binding generation, resulting
-in build failures.
-
-Workaround this by commenting out `FILE_PATTERNS`.
-
-Upstream-issue: https://github.com/doxygen/doxygen/issues/7190
----
- Doxyfile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Doxyfile b/Doxyfile
-index 252e504e..729340e2 100644
---- a/Doxyfile
-+++ b/Doxyfile
-@@ -763,7 +763,7 @@ INPUT_ENCODING = UTF-8
- # *.md, *.mm, *.dox, *.py, *.f90, *.f, *.for, *.tcl, *.vhd, *.vhdl, *.ucf,
- # *.qsf, *.as and *.js.
-
--FILE_PATTERNS =
-+#FILE_PATTERNS =
-
- # The RECURSIVE tag can be used to specify whether or not subdirectories should
- # be searched for input files as well.
---
-2.23.0
-
diff --git a/PKGBUILD b/PKGBUILD
index c5e8d2470aa5..b03821e2f49c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_gitname='libsigrok'
pkgname="${_gitname}-git"
-pkgver=0.2.1.r3425.gf6129c8f
+pkgver=0.2.1.r3429.g02a8c07d
pkgrel=1
pkgdesc="Client software that supports various hardware logic analyzers, core library (git version)"
arch=('armv6h' 'armv7h' 'i686' 'x86_64')
@@ -16,27 +16,23 @@ makedepends=('git' 'autoconf-archive' 'doxygen')
conflicts=("${_gitname}")
provides=("${_gitname}")
source=("git://sigrok.org/${_gitname}"
- "file://0001-doxyfile-work-around-doxygen-1.8.16-bug.patch"
)
-sha512sums=('SKIP' 'SKIP')
+sha512sums=('SKIP')
pkgver() {
cd "${srcdir}/${_gitname}"
git describe --exclude 'libsigrok-unreleased' --long | sed 's/^libsigrok-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "${srcdir}/${_gitname}"
- patch -Np1 <../0001-doxyfile-work-around-doxygen-1.8.16-bug.patch
-}
-
build() {
+ rm -rf "${srcdir}/build"
mkdir -p "${srcdir}/build"
cd "${srcdir}/${_gitname}"
./autogen.sh
cd "${srcdir}/build"
- ../${_gitname}/configure --prefix=/usr --disable-java
+ echo "CONFIGURE"
+ ../${_gitname}/configure --prefix=/usr --disable-java --disable-ruby
make
}