summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody P Schafer2018-08-13 00:11:44 -0400
committerCody P Schafer2018-08-13 00:11:44 -0400
commit04838b34cea1e34bba0a5d8e8200b7635da2a67c (patch)
tree877848c5618460ebe07d9171d0e458e2f23c28d9
parentf148ea49927c4015d03be41ba2e909f421bc8c4c (diff)
downloadaur-04838b34cea1e34bba0a5d8e8200b7635da2a67c.tar.gz
version 0.99
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3544ce2f9ece..555ddd9a03b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libsigrokdecode4dsl
pkgdesc = A library which provides the basic sigrok protocol decoders for DreamSourceLab hardware
- pkgver = 0.98
+ pkgver = 0.99
pkgrel = 1
url = https://github.com/DreamSourceLab/DSView
arch = i686
@@ -9,8 +9,8 @@ pkgbase = libsigrokdecode4dsl
makedepends = git
depends = python
depends = glib2
- source = git://github.com/DreamSourceLab/DSView.git#tag=0.98
- sha1sums = SKIP
+ source = DSView-0.99.tar.gz::https://github.com/DreamSourceLab/DSView/archive/0.99.tar.gz
+ sha384sums = 9f92432c1721d5e39b343029955c95203bf9cf051095956175e7315e0471bbc01c8ba85708ed3eb085a7cf75932adb6c
pkgname = libsigrokdecode4dsl
diff --git a/PKGBUILD b/PKGBUILD
index fa05c63e80ed..3895562035ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
pkgname=libsigrokdecode4dsl
-pkgver=0.98
+pkgver=0.99
pkgrel=1
pkgdesc='A library which provides the basic sigrok protocol decoders for DreamSourceLab hardware'
url='https://github.com/DreamSourceLab/DSView'
@@ -10,11 +10,17 @@ arch=(i686 x86_64)
license=(GPL3)
depends=(python glib2)
makedepends=(git)
-source=("git://github.com/DreamSourceLab/DSView.git#tag=$pkgver")
-sha1sums=('SKIP')
+source=(
+ "DSView-$pkgver.tar.gz::https://github.com/DreamSourceLab/DSView/archive/${pkgver}.tar.gz"
+)
+sha384sums=('9f92432c1721d5e39b343029955c95203bf9cf051095956175e7315e0471bbc01c8ba85708ed3eb085a7cf75932adb6c')
+
+_wdir() {
+ cd "$srcdir/DSView-$pkgver/libsigrokdecode4DSL"
+}
build() {
- cd DSView/libsigrokdecode4DSL
+ _wdir
./autogen.sh
./configure --prefix=/usr
@@ -23,6 +29,6 @@ build() {
}
package() {
- cd DSView/libsigrokdecode4DSL
+ _wdir
make DESTDIR="$pkgdir" PREFIX=/usr install
}