summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaurizio D'Addona2014-12-30 09:37:16 +0100
committerMaurizio D'Addona2014-12-30 09:37:16 +0100
commit70a5397f7d6a3258aa4bbf2cc0d409c96137cb43 (patch)
tree175b15c885af72921e0fa2e261cab326594dd178
downloadaur-70a5397f7d6a3258aa4bbf2cc0d409c96137cb43.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD53
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d302328f31af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libsnl-svn
+ pkgdesc = libSNL is a library of routines used for the manipulation of NURBS curves and surfaces.
+ pkgver = 18
+ pkgrel = 4
+ url = http://libsnl.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = svn
+ provides = libsnl
+ conflicts = libsnl
+ source = libsnl::svn://svn.code.sf.net/p/libsnl/code/trunk
+ md5sums = SKIP
+
+pkgname = libsnl-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65d819ddfdbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Maurizio D'Addona <mauritiusdadd@gmail.com>
+
+_svnname='libsnl'
+
+pkgname=libsnl-svn
+pkgver=18
+pkgrel=4
+pkgdesc="libSNL is a library of routines used for the manipulation of NURBS curves and surfaces."
+arch=('i686' 'x86_64')
+url="http://libsnl.sourceforge.net/"
+license=('GPL2')
+provides=('libsnl')
+conflicts=('libsnl')
+depends=()
+makedepends=('svn')
+
+source=("$_svnname::svn://svn.code.sf.net/p/$_svnname/code/trunk")
+md5sums=('SKIP')
+
+pkgver()
+{
+ cd "$srcdir/$_svnname"
+ local ver="$(svnversion)"
+ printf "%s" "${ver//[[:alpha:]]}"
+}
+
+prepare()
+{
+ cd "$srcdir/$_svnname/src"
+ oldflags="export cflags = -Wall -fPIC -g"
+ newflags="export cflags = -Wall -fPIC -O2 -g"
+ sed -i -e "s/$oldflags/$newflags/g" ./makefile
+}
+
+build()
+{
+ cd "$srcdir/$_svnname/src"
+ msg "Building..."
+ export CXXFLAGS="${CXXFLAGS} -O2"
+ export CFLAGS="${CFLAGS} -O2"
+ make
+ msg2 "Build complete."
+}
+
+package()
+{
+ cd "$srcdir/$_svnname/src"
+ msg "Copying files..."
+ install -Dm644 libSNL.so.0.2 $pkgdir/usr/lib/libSNL.so.0.2
+ ln -s libSNL.so.0.2 $pkgdir/usr/lib/libSNL.so
+ install -d $pkgdir/usr/include/libSNL
+ cp *.h $pkgdir/usr/include/libSNL
+} \ No newline at end of file