summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksy Grabowski2021-02-06 00:40:55 +0100
committerAleksy Grabowski2021-02-06 00:40:55 +0100
commitcd335c507b36ad36c77f1c0e480015b1ed88086f (patch)
tree2a09fb7ff05ccc26f9c81cea0f382ed5bde3da30
parent92266838bf7ca627240a07d97581e54a018e3368 (diff)
downloadaur-libsocket.tar.gz
Add package based on official release 2.5.0
-rw-r--r--.SRCINFO13
-rw-r--r--Dockerfile2
-rw-r--r--PKGBUILD31
3 files changed, 19 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0192b815d191..3ffa7d80239e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = libsocket-git
+pkgbase = libsocket
pkgdesc = Library with a C part and a C++ part making sockets usage easy and clean
- pkgver = 2.5.0.r25.g706649c
+ pkgver = 2.5.0
pkgrel = 1
url = http://dermesser.github.io/libsocket/doc/
arch = i686
@@ -11,9 +11,10 @@ pkgbase = libsocket-git
provides = libsocket
provides = libsocket++.so=libsocket++.so-64
provides = libsocket.so=libsocket.so-64
- conflicts = libsocket
- source = git+https://github.com/dermesser/libsocket.git
- md5sums = SKIP
+ source = https://github.com/dermesser/libsocket/archive/v2.5.0.tar.gz
+ md5sums = 43a38b76b7fa5387147d1589c5314e03
+ sha1sums = 3dc272e01830357c64af888bb084be87493ef795
+ sha256sums = 0afe2ece985caa0b44546d10426b15a506164d5b96d7242890c7d0337f479689
-pkgname = libsocket-git
+pkgname = libsocket
diff --git a/Dockerfile b/Dockerfile
index 3033513636b5..214c83142997 100644
--- a/Dockerfile
+++ b/Dockerfile
@@ -8,7 +8,7 @@ RUN pacman -S --noconfirm --needed base-devel namcap
# Configuration
ARG DOCKER_USER=buildbot
-ARG DOCKER_PROJECT=libsocket-git
+ARG DOCKER_PROJECT=libsocket
# Creating new user
RUN useradd --base-dir /home -m --shell /bin/sh --gid root --comment "Build Bot,$HOSTNAME,,," "$DOCKER_USER"
diff --git a/PKGBUILD b/PKGBUILD
index 390bd95485dd..95584bae564a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Aleksy Grabowski <hurufu@gmail.com>
-pkgname=libsocket-git
-pkgver=2.5.0.r25.g706649c
+pkgname=libsocket
+pkgver=2.5.0
pkgrel=1
pkgdesc='Library with a C part and a C++ part making sockets usage easy and clean'
arch=('i686' 'x86_64')
@@ -17,24 +17,15 @@ provides=(
libsocket++.so=libsocket++.so-64
libsocket.so=libsocket.so-64
)
-conflicts=(
- libsocket
-)
-
-source=(
- 'git+https://github.com/dermesser/libsocket.git'
-)
-md5sums=(
- 'SKIP'
-)
-pkgver() {
- git -C "$srcdir/libsocket" describe | awk -F - '{ print substr($1,2)".r"$2"."$3 }'
-}
+source=("https://github.com/dermesser/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=(43a38b76b7fa5387147d1589c5314e03)
+sha1sums=(3dc272e01830357c64af888bb084be87493ef795)
+sha256sums=(0afe2ece985caa0b44546d10426b15a506164d5b96d7242890c7d0337f479689)
build() {
- mkdir -p libsocket/build
- cd libsocket/build
+ mkdir -p "libsocket-$pkgver/build"
+ cd "libsocket-$pkgver/build"
cmake \
-Wno-dev \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -44,8 +35,8 @@ build() {
}
package() {
- make -C libsocket/build DESTDIR="$pkgdir" install
- install -Dm644 "$srcdir/libsocket/LICENSE" "$pkgdir/usr/share/licenses/libsocket/LICENSE"
+ make -C "libsocket-$pkgver/build" DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir/libsocket-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/libsocket/LICENSE"
mkdir -p "$pkgdir/usr/share/doc/libsocket"
- cp -rt "$pkgdir/usr/share/doc/libsocket" "$srcdir"/libsocket/examples*
+ cp -rt "$pkgdir/usr/share/doc/libsocket" "$srcdir/libsocket-$pkgver"/examples*
}