summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Gizdov2021-09-09 13:46:49 +0300
committerKonstantin Gizdov2021-09-09 13:46:49 +0300
commita02487c6a2d5b468d3a82ae82020d3c8ac58da0e (patch)
treec36ded282583d794a4b00cadff7701398bd20c5e
downloadaur-libsocketcan-git.tar.gz
initial release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD31
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71608ffc20c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = libsocketcan-git
+ pkgdesc = allows control of some basic functions in SocketCAN from userspace
+ pkgver = r101.b464485
+ pkgrel = 1
+ url = http://lalten.github.io/libsocketcan/
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ source = libsocketcan::git+https://github.com/lalten/libsocketcan#branch=gh-pages
+ sha256sums = SKIP
+
+pkgname = libsocketcan-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb92b9cd999c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Konstantin Gizdov arch at kge dot pw
+
+_pkgname=libsocketcan
+pkgname="${_pkgname}-git"
+pkgver=r101.b464485
+pkgrel=1
+source=("${_pkgname}::git+https://github.com/lalten/libsocketcan#branch=gh-pages")
+sha256sums=('SKIP')
+arch=('x86_64')
+makedepends=('git')
+pkgdesc='allows control of some basic functions in SocketCAN from userspace'
+license=('LGPL2.1')
+url='http://lalten.github.io/libsocketcan/'
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build () {
+ cd "${srcdir}/${_pkgname}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ # fix missing build rule
+ cp README.md README
+ make
+}
+
+package () {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}