summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSahan Fernando2015-09-06 19:32:07 +1000
committerSahan Fernando2015-09-06 19:32:07 +1000
commit06bbaa8031f5e7aab1a8b7afd5156bda0e3281c2 (patch)
tree12e720d9c330c7055c93d2800a4e4d6b5616ee76
downloadaur-06bbaa8031f5e7aab1a8b7afd5156bda0e3281c2.tar.gz
Created repo
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
-rw-r--r--jack1_compat.patch4
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..157193b1248b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libsoundio-git
+ pkgdesc = A C99 library providing cross-platform audio input and output
+ pkgver = 20150906
+ pkgrel = 1
+ url = http://www.github.com/andrewrk/libsoundio
+ arch = x86_64
+ license = MIT
+ options = !buildflags
+ source = git://github.com/andrewrk/libsoundio
+ source = jack1_compat.patch
+ md5sums = SKIP
+ md5sums = e25c3e74405dfd34ed85e9e36fe52922
+
+pkgname = libsoundio-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b4f6cc8bea2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Carlos Rivas <carlos (a t) twobitcoder (do t) com>
+# Contributor: Joost Bremmer <toost dot b at gmail dot com>
+
+pkgname=libsoundio-git
+pkgver=20150906
+pkgrel=1
+pkgdesc="A C99 library providing cross-platform audio input and output"
+arch=('x86_64')
+url="http://www.github.com/andrewrk/libsoundio"
+license=('MIT')
+source=("git://github.com/andrewrk/libsoundio"
+ "jack1_compat.patch")
+options=('!buildflags')
+md5sums=('SKIP'
+'e25c3e74405dfd34ed85e9e36fe52922')
+
+prepare(){
+ cd ${srcdir}/libsoundio
+
+ # reverts to a known build of libsoundio, remove if you wnat the newest
+ git revert 'e2e483a4d523acab5a580b1e58a6ebc218da8f5e' --no-edit
+
+ # jack1 compatibilty for this library is currently broken, and
+ # as a result it won't build at all unless you disable it
+ patch CMakeLists.txt ../jack1_compat.patch
+}
+
+build() {
+ cd ${srcdir}/libsoundio
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX:PATH="${pkgdir}/usr/" .. && make
+}
+
+package() {
+ cd ${srcdir}/libsoundio/build
+ make install
+}
diff --git a/jack1_compat.patch b/jack1_compat.patch
new file mode 100644
index 000000000000..139ed631f288
--- /dev/null
+++ b/jack1_compat.patch
@@ -0,0 +1,4 @@
+30c30
+< option(ENABLE_JACK "Enable JACK backend" ON)
+---
+> option(ENABLE_JACK "Enable JACK backend" OFF)