summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEwout van Mansom2023-04-28 14:10:41 +0200
committerEwout van Mansom2023-04-28 14:10:41 +0200
commit9d5c49e0f925990c041f5e158f2cc7f498da03b0 (patch)
tree24ab28304c82213fec3711ebda693e74700d056d
parent70fb3a6369b874f213793e221cc75480a0b2f37f (diff)
downloadaur-libstumpless.tar.gz
update patch once again
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--pr340.patch18
3 files changed, 10 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 302b842a8de5..48a47cfd93d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libstumpless
pkgdesc = C logging library built for high performance and a rich feature set.
pkgver = 2.1.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/goatshriek/stumpless
arch = i686
arch = x86_64
@@ -17,6 +17,6 @@ pkgbase = libstumpless
source = stumpless-2.1.0.tar.gz::https://github.com/goatshriek/stumpless/archive/refs/tags/v2.1.0.tar.gz
source = pr340.patch::https://patch-diff.githubusercontent.com/raw/goatshriek/stumpless/pull/340.patch
sha256sums = f3eff944d81fdf82ffe5c0df6a8c692224140c9c322ffc3ba709218a66dc07ec
- sha256sums = e0a76a2b036fecf493a6585ead1c7ae8501818a54202125771296b5e2456aa77
+ sha256sums = 42a1ddca300bdbbee147dba0eab7e77c839209a7e772b922e4ee60e28169b9a9
pkgname = libstumpless
diff --git a/PKGBUILD b/PKGBUILD
index 9d37137a4a8c..d777be0b5dc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=libstumpless
_projname=stumpless
pkgver=2.1.0
-pkgrel=5
+pkgrel=6
pkgdesc='C logging library built for high performance and a rich feature set.'
arch=('i686' 'x86_64' 'aarch64')
url='https://github.com/goatshriek/stumpless'
@@ -15,7 +15,7 @@ provides=('libstumpless' 'libstumpless.so')
source=("${_projname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz"
'pr340.patch::https://patch-diff.githubusercontent.com/raw/goatshriek/stumpless/pull/340.patch')
sha256sums=('f3eff944d81fdf82ffe5c0df6a8c692224140c9c322ffc3ba709218a66dc07ec'
- 'e0a76a2b036fecf493a6585ead1c7ae8501818a54202125771296b5e2456aa77')
+ '42a1ddca300bdbbee147dba0eab7e77c839209a7e772b922e4ee60e28169b9a9')
prepare() {
cd "${_projname}-${pkgver}"
diff --git a/pr340.patch b/pr340.patch
index b9d5b89b9802..95feefcb6e86 100644
--- a/pr340.patch
+++ b/pr340.patch
@@ -1,24 +1,18 @@
-From 431467bad477b8d9440ecf2a9374f69ed560a85e Mon Sep 17 00:00:00 2001
+From da8e2907db1f0822e151f90ff754eec489c8c822 Mon Sep 17 00:00:00 2001
From: Ewout van Mansom <ewout@vanmansom.name>
Date: Mon, 24 Apr 2023 14:12:28 +0200
Subject: [PATCH] add pkg-config file (#339)
---
- CMakeLists.txt | 9 ++++++++-
+ CMakeLists.txt | 7 +++++++
tools/pkg-config/stumpless.pc.in | 10 ++++++++++
- 2 files changed, 18 insertions(+), 1 deletion(-)
+ 2 files changed, 17 insertions(+)
create mode 100644 tools/pkg-config/stumpless.pc.in
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index c9946ce6..8de594ce 100644
+index c9946ce6..e51023c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -1,4 +1,4 @@
--cmake_minimum_required(VERSION 3.2.3)
-+cmake_minimum_required(VERSION 3.12)
-
- if(POLICY CMP0135)
- cmake_policy(SET CMP0135 NEW)
@@ -1000,6 +1000,13 @@ install(FILES
include(tools/cmake/cpack.cmake)
@@ -35,7 +29,7 @@ index c9946ce6..8de594ce 100644
add_function_test(buffer
diff --git a/tools/pkg-config/stumpless.pc.in b/tools/pkg-config/stumpless.pc.in
new file mode 100644
-index 00000000..d0d5b84f
+index 00000000..b8c573bc
--- /dev/null
+++ b/tools/pkg-config/stumpless.pc.in
@@ -0,0 +1,10 @@
@@ -46,6 +40,6 @@ index 00000000..d0d5b84f
+
+Name: @CMAKE_PROJECT_NAME@
+Description: C logging library built for high performance and a rich feature set
-+Version: @CMAKE_PROJECT_VERSION@
++Version: @PROJECT_VERSION@
+Libs: -L${libdir} -lstumpless
+Cflags: -I${includedir}