summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Vogt2015-06-17 10:37:42 +0200
committerDavid Vogt2015-06-17 10:37:42 +0200
commitb175585de7d1d5ec22fc5aa693f25ff32642934b (patch)
tree88bfa39ff59fb99776bd1e7180186352aaa575cd
downloadaur-libtermkey-git.tar.gz
initial, moved over from http://github.com/winged/aur-packages
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..556b562c1f73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libtermkey-git
+ pkgdesc = This library allows easy processing of keyboard entry from terminal-based programs. It handles all the necessary logic to recognise special keys, UTF-8 combining, and so on, with a simple interface.
+ pkgver = 0.r351.87a4d22
+ pkgrel = 1
+ url = http://www.leonerd.org.uk/code/libtermkey/
+ arch = x86_64
+ arch = i686
+ license = MIT
+ provides = libtermkey
+ conflicts = libtermkey
+ source = libtermkey-git::git://github.com/neovim/libtermkey.git
+ source = LICENSE::https://raw.githubusercontent.com/neovim/libtermkey/master/LICENSE
+ sha256sums = SKIP
+ sha256sums = d2d251b07bfd2cf6b32cf392752975a693be89dd1f0baa712ee6b5e20b9c0835
+
+pkgname = libtermkey-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afe1cb0b5f39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: David Vogt <dave at winged dot ch>
+# This PKGBUILD is maintained at https://github.com/winged/aur-packages
+
+pkgname=libtermkey-git
+pkgver=0.r351.87a4d22
+pkgrel=1
+pkgdesc="This library allows easy processing of keyboard entry from terminal-based programs. It handles all the necessary logic to recognise special keys, UTF-8 combining, and so on, with a simple interface."
+arch=('x86_64' 'i686')
+license=('MIT')
+url=('http://www.leonerd.org.uk/code/libtermkey/')
+#depends=()
+provides=('libtermkey')
+conflicts=('libtermkey')
+#makedepends=('python2-setuptools')
+source=("$pkgname::git://github.com/neovim/libtermkey.git"
+ "LICENSE::https://raw.githubusercontent.com/neovim/libtermkey/master/LICENSE")
+sha256sums=('SKIP' 'd2d251b07bfd2cf6b32cf392752975a693be89dd1f0baa712ee6b5e20b9c0835')
+pkgver() {
+ cd "${pkgname}"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+# vim:set ts=2 sw=2 et: