summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-02-14 01:08:49 -0500
committerJames An2015-02-14 01:08:49 -0500
commit504afec6ae0ea3b60e5337dda52f0219feb6ef09 (patch)
tree8405b65872b644aaa8719035a3079816b75663e3
parentc77dbf2fcd4d60f08a678dc5f7bd5c8d9b9faf4d (diff)
downloadaur-504afec6ae0ea3b60e5337dda52f0219feb6ef09.tar.gz
Fixed libtomcrypt license terms and added the upstream signature for its source files.
-rw-r--r--PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dcdc20fe65e8..a7bbdb4f4acc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,25 @@
+# Maintainer: James An <james@jamesan.ca>
# Contributor: Michael Fellinger <m.fellinger@gmail.com>
-pkgname=libtomcrypt
+
_pkgname=crypt
+pkgname="libtom$_pkgname"
pkgver=1.17
-pkgrel=8
-pkgdesc="Comprehensive, modular, and portable cryptographic toolkit/library."
-url="http://libtom.org/?page=features&whatfile=crypt"
-license="public domain"
+pkgrel=9
+pkgdesc="A fairly comprehensive, modular and portable cryptographic toolkit"
+url="http://libtom.net/?page=features&newsitems=5&whatfile=$_pkgname"
+license=('custom:Public Domain' 'custom:WTFPL')
arch=('i686' 'x86_64')
depends=('gmp')
-makedepends=('gmp' 'libtommath')
-conflicts=()
-replaces=()
-backup=()
+makedepends=('libtommath')
options=('!emptydirs')
-source=("http://libtom.org/files/${_pkgname}-${pkgver}.tar.bz2")
-md5sums=('cea7e5347979909f458fe7ebb5a44f85')
+source=(
+ "http://libtom.net/files/${_pkgname}-${pkgver}.tar.bz2"
+ "http://libtom.net/files/${_pkgname}-${pkgver}.tar.bz2.sig"
+)
+md5sums=('cea7e5347979909f458fe7ebb5a44f85'
+ 'SKIP')
-build() {
+package() {
cd ${srcdir}/$pkgname-$pkgver
make NODOCS=1 DESTDIR="$pkgdir" install
make NODOCS=1 DESTDIR="$pkgdir" clean