summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-02-13 23:32:50 -0500
committerJames An2015-02-13 23:32:50 -0500
commitc77dbf2fcd4d60f08a678dc5f7bd5c8d9b9faf4d (patch)
tree8f6fe1e8c3c1168f2de16bf4047e4d454c5de87e
downloadaur-c77dbf2fcd4d60f08a678dc5f7bd5c8d9b9faf4d.tar.gz
Added libtomcrypt from the AUR.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78387aaee643
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libtomcrypt
+ pkgdesc = A fairly comprehensive, modular and portable cryptographic toolkit
+ pkgver = 1.17
+ pkgrel = 9
+ url = http://libtom.net/?page=features&newsitems=5&whatfile=crypt
+ arch = i686
+ arch = x86_64
+ license = custom:Public Domain
+ license = custom:WTFPL
+ makedepends = libtommath
+ depends = gmp
+ options = !emptydirs
+ source = http://libtom.net/files/crypt-1.17.tar.bz2
+ source = http://libtom.net/files/crypt-1.17.tar.bz2.sig
+ md5sums = cea7e5347979909f458fe7ebb5a44f85
+ md5sums = SKIP
+
+pkgname = libtomcrypt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dcdc20fe65e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Michael Fellinger <m.fellinger@gmail.com>
+pkgname=libtomcrypt
+_pkgname=crypt
+pkgver=1.17
+pkgrel=8
+pkgdesc="Comprehensive, modular, and portable cryptographic toolkit/library."
+url="http://libtom.org/?page=features&whatfile=crypt"
+license="public domain"
+arch=('i686' 'x86_64')
+depends=('gmp')
+makedepends=('gmp' 'libtommath')
+conflicts=()
+replaces=()
+backup=()
+options=('!emptydirs')
+source=("http://libtom.org/files/${_pkgname}-${pkgver}.tar.bz2")
+md5sums=('cea7e5347979909f458fe7ebb5a44f85')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+ make NODOCS=1 DESTDIR="$pkgdir" install
+ make NODOCS=1 DESTDIR="$pkgdir" clean
+ CFLAGS="-DLTM_DESC -DGMP_DESC" \
+ EXTRALIBS="-ltommath -lgmp" \
+ make -f makefile.shared NODOCS=1 DESTDIR="$pkgdir" install
+}