summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Vihrov2017-02-15 19:24:59 +0200
committerAndrey Vihrov2017-02-15 19:24:59 +0200
commiteb350d253bd0e7a485c4575b71adb31653d5c4f2 (patch)
tree66c8c1cd8402495ec4964e605ba1425d1c8e14be
parentea0d631c4fdbf21ed2c0dfa82b31907cfbd40688 (diff)
downloadaur-eb350d253bd0e7a485c4575b71adb31653d5c4f2.tar.gz
Fix install problems
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e43a48ed9a1..ba833fd50053 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,6 +13,13 @@ depends=('libtommath' 'gmp')
source=("https://github.com/libtom/${pkgname}/releases/download/${pkgver}/${pkgname#libtom}-${pkgver}.tar.bz2")
sha256sums=('e33b47d77a495091c8703175a25c8228aff043140b2554c08a3c3cd71f79d116')
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ # Fix permissions on header files
+ sed -i -e '/$(HEADERS)/s/install/\0 -m 0644/' makefile.shared
+}
+
build() {
cd "${pkgname}-${pkgver}"
@@ -24,5 +31,5 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
- make -f makefile.shared DESTDIR="${pkgdir}" install
+ make -f makefile.shared DESTDIR="${pkgdir}" INSTALL_GROUP="root" install
}