summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Küthe2024-01-17 01:00:19 +0000
committerMarek Küthe2024-01-17 01:00:19 +0000
commit2669a1af56d4cd33539df59e6e3572d2bfbe0521 (patch)
tree4998f73fb977a058292fdde8953e6d5dfbcbb1ec
parent9c282d3660a00462b490a8c463d4e9d27ab1da4f (diff)
downloadaur-libtuntap-git.tar.gz
Update style
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 7 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 022173f03465..cfc4237589aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libtuntap-git
pkgdesc = The portable Tun/Tap devices configuration utility
- pkgver = 0.4.r63.gc642154
- pkgrel = 2
+ pkgver = 0.4.r70.g18ee864
+ pkgrel = 1
url = https://github.com/LaKabane/libtuntap/
arch = x86_64
license = ISC
diff --git a/PKGBUILD b/PKGBUILD
index 8140364eae0e..53055a7bcd3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=libtuntap
pkgname=libtuntap-git
-pkgver=0.4.r63.gc642154
-pkgrel=2
+pkgver=0.4.r70.g18ee864
+pkgrel=1
pkgdesc="The portable Tun/Tap devices configuration utility"
arch=('x86_64')
url="https://github.com/LaKabane/libtuntap/"
@@ -18,16 +18,10 @@ pkgver() {
}
build() {
- cd "$_pkgname"
-
- mkdir build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
- make -j "$(nproc)"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -B build -S "$_pkgname"
+ cmake --build build
}
package() {
- cd "$_pkgname/build"
-
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" cmake --install build
}